summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-cffi/package.py
diff options
context:
space:
mode:
authorTodd Gamblin <tgamblin@llnl.gov>2015-11-26 14:19:27 -0800
committerTodd Gamblin <tgamblin@llnl.gov>2015-11-26 14:19:27 -0800
commit89d5127900dda96b2a583c4c1a9bdac8e51c1c15 (patch)
treefe491c5c4046702cc9ddb84d63375e28a610f1b1 /var/spack/repos/builtin/packages/py-cffi/package.py
parent04f032d6e397ce219a673c93277683060def52fd (diff)
downloadspack-89d5127900dda96b2a583c4c1a9bdac8e51c1c15.tar.gz
spack-89d5127900dda96b2a583c4c1a9bdac8e51c1c15.tar.bz2
spack-89d5127900dda96b2a583c4c1a9bdac8e51c1c15.tar.xz
spack-89d5127900dda96b2a583c4c1a9bdac8e51c1c15.zip
New, cleaner package repository structure.
Package repositories now look like this: top-level-dir/ repo.yaml packages/ libelf/ package.py mpich/ package.py ... This leaves room at the top level for additional metadata, source, per-repo configs, indexes, etc., and it makes it easy to see that something is a spack repo (just look for repo.yaml and packages).
Diffstat (limited to 'var/spack/repos/builtin/packages/py-cffi/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-cffi/package.py17
1 files changed, 17 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/py-cffi/package.py b/var/spack/repos/builtin/packages/py-cffi/package.py
new file mode 100644
index 0000000000..a4d37483fe
--- /dev/null
+++ b/var/spack/repos/builtin/packages/py-cffi/package.py
@@ -0,0 +1,17 @@
+from spack import *
+
+class PyCffi(Package):
+ """Foreign Function Interface for Python calling C code"""
+ homepage = "http://cffi.readthedocs.org/en/latest/"
+ # base https://pypi.python.org/pypi/cffi
+ url = "https://pypi.python.org/packages/source/c/cffi/cffi-1.1.2.tar.gz#md5="
+
+ version('1.1.2', 'ca6e6c45b45caa87aee9adc7c796eaea')
+
+ extends('python')
+ depends_on('py-setuptools')
+ depends_on('py-pycparser')
+ depends_on('libffi')
+
+ def install(self, spec, prefix):
+ python('setup.py', 'install', '--prefix=%s' % prefix)