summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-gosam/package.py
diff options
context:
space:
mode:
authorTodd Gamblin <tgamblin@llnl.gov>2022-07-30 15:19:18 -0700
committerTodd Gamblin <tgamblin@llnl.gov>2022-07-31 13:29:20 -0700
commitf52f6e99dbf1131886a80112b8c79dfc414afb7c (patch)
tree05cb7d64b2395922f2f24683da49f472075be12c /var/spack/repos/builtin/packages/py-gosam/package.py
parent549ba1ed32372c67fc57271cde3797d58b7dec6e (diff)
downloadspack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.gz
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.bz2
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.xz
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.zip
black: reformat entire repository with black
Diffstat (limited to 'var/spack/repos/builtin/packages/py-gosam/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-gosam/package.py52
1 files changed, 29 insertions, 23 deletions
diff --git a/var/spack/repos/builtin/packages/py-gosam/package.py b/var/spack/repos/builtin/packages/py-gosam/package.py
index 930491e410..b8842ac8c2 100644
--- a/var/spack/repos/builtin/packages/py-gosam/package.py
+++ b/var/spack/repos/builtin/packages/py-gosam/package.py
@@ -8,32 +8,38 @@ from spack.package import *
class PyGosam(Package):
"""The package GoSam allows for the automated calculation of
- one-loop amplitudes for multi-particle processes in renormalizable
- quantum field theories."""
+ one-loop amplitudes for multi-particle processes in renormalizable
+ quantum field theories."""
homepage = "https://github.com/gudrunhe/gosam"
- git = "https://github.com/gudrunhe/gosam.git"
-
- tags = ['hep']
-
- extends('python')
-
- version('2.1.1', url="https://github.com/gudrunhe/gosam/releases/download/2.1.1/gosam-2.1.1-4b98559.tar.gz",
- sha256="4a2b9160d51e3532025b9579a4d17d0e0f8a755b8481aeb8271c1f58eb97ab01")
- version('2.0.4', sha256='faf621c70f66d9dffc16ac5cce66258067f39f686d722a4867eeb759fcde4f44',
- url='https://gosam.hepforge.org/downloads/?f=gosam-2.0.4-6d9f1cba.tar.gz')
- version('2.0.3', tag='v2.0.3', commit='4146ab23a06b7c57c10fb36df60758d34aa58387')
-
- depends_on('form', type='run')
- depends_on('qgraf', type='run')
- depends_on('gosam-contrib', type='link')
- depends_on('python@2.7.0:2.7', type=('build', 'run'), when='@:2.0.4')
- depends_on('python@3:', type=('build', 'run'), when='@2.1.1:')
+ git = "https://github.com/gudrunhe/gosam.git"
+
+ tags = ["hep"]
+
+ extends("python")
+
+ version(
+ "2.1.1",
+ url="https://github.com/gudrunhe/gosam/releases/download/2.1.1/gosam-2.1.1-4b98559.tar.gz",
+ sha256="4a2b9160d51e3532025b9579a4d17d0e0f8a755b8481aeb8271c1f58eb97ab01",
+ )
+ version(
+ "2.0.4",
+ sha256="faf621c70f66d9dffc16ac5cce66258067f39f686d722a4867eeb759fcde4f44",
+ url="https://gosam.hepforge.org/downloads/?f=gosam-2.0.4-6d9f1cba.tar.gz",
+ )
+ version("2.0.3", tag="v2.0.3", commit="4146ab23a06b7c57c10fb36df60758d34aa58387")
+
+ depends_on("form", type="run")
+ depends_on("qgraf", type="run")
+ depends_on("gosam-contrib", type="link")
+ depends_on("python@2.7.0:2.7", type=("build", "run"), when="@:2.0.4")
+ depends_on("python@3:", type=("build", "run"), when="@2.1.1:")
def setup_run_environment(self, env):
- gosam_contrib_lib_dir = self.spec['gosam-contrib'].prefix.lib
- env.prepend_path('LD_LIBRARY_PATH', gosam_contrib_lib_dir)
+ gosam_contrib_lib_dir = self.spec["gosam-contrib"].prefix.lib
+ env.prepend_path("LD_LIBRARY_PATH", gosam_contrib_lib_dir)
def install(self, spec, prefix):
- python('-s', 'setup.py', '--no-user-cfg', 'build')
- python('-s', 'setup.py', '--no-user-cfg', 'install', '--prefix=' + prefix)
+ python("-s", "setup.py", "--no-user-cfg", "build")
+ python("-s", "setup.py", "--no-user-cfg", "install", "--prefix=" + prefix)