summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-iminuit
diff options
context:
space:
mode:
authorAdam J. Stewart <ajstewart426@gmail.com>2016-06-10 09:24:52 -0500
committerAdam J. Stewart <ajstewart426@gmail.com>2016-06-17 10:43:34 -0500
commita660c60eb1997317fe0e99054a99cc1cea1d3a56 (patch)
tree700263b5d0778d2e72c134dcc5768f3e42011288 /var/spack/repos/builtin/packages/py-iminuit
parentf351e011d1f91372492651829b9dd82d81cd191d (diff)
downloadspack-a660c60eb1997317fe0e99054a99cc1cea1d3a56.tar.gz
spack-a660c60eb1997317fe0e99054a99cc1cea1d3a56.tar.bz2
spack-a660c60eb1997317fe0e99054a99cc1cea1d3a56.tar.xz
spack-a660c60eb1997317fe0e99054a99cc1cea1d3a56.zip
Add py-sncosmo package
Diffstat (limited to 'var/spack/repos/builtin/packages/py-iminuit')
-rw-r--r--var/spack/repos/builtin/packages/py-iminuit/package.py54
1 files changed, 54 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/py-iminuit/package.py b/var/spack/repos/builtin/packages/py-iminuit/package.py
new file mode 100644
index 0000000000..5a42268a73
--- /dev/null
+++ b/var/spack/repos/builtin/packages/py-iminuit/package.py
@@ -0,0 +1,54 @@
+##############################################################################
+# Copyright (c) 2013-2016, Lawrence Livermore National Security, LLC.
+# Produced at the Lawrence Livermore National Laboratory.
+#
+# This file is part of Spack.
+# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
+# LLNL-CODE-647188
+#
+# For details, see https://github.com/llnl/spack
+# Please also see the LICENSE file for our notice and the LGPL.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License (as
+# published by the Free Software Foundation) version 2.1, February 1999.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
+# conditions of the GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+##############################################################################
+from spack import *
+
+
+class PyIminuit(Package):
+ """Interactive IPython-Friendly Minimizer based on SEAL Minuit2."""
+
+ homepage = "https://pypi.python.org/pypi/iminuit"
+ url = "https://pypi.python.org/packages/source/i/iminuit/iminuit-1.2.tar.gz"
+
+ version('1.2', '4701ec472cae42015e26251703e6e984')
+
+ # Required dependencies
+ extends('python@2.7:2.8,3.4:')
+ depends_on('py-setuptools')
+
+ # Optional dependencies
+ depends_on('py-numpy')
+ depends_on('py-matplotlib')
+
+ def install(self, spec, prefix):
+ site_packages = '{0}/lib/python{1}/site-packages'.format(
+ prefix, spec['python'].version.up_to(2))
+
+ # site-packages directory must already exist
+ mkdirp(site_packages)
+
+ # PYTHONPATH must include site-packages directory
+ env['PYTHONPATH'] += ':{0}'.format(site_packages)
+
+ python('setup.py', 'install', '--prefix={0}'.format(prefix))