summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-mxnet
diff options
context:
space:
mode:
author健美猫 <weijianwen@gmail.com>2017-10-11 04:56:26 +0800
committerTodd Gamblin <tgamblin@llnl.gov>2017-10-10 13:56:26 -0700
commit9e95e8394e9ddb0e20419688cc6e1d1507b351a1 (patch)
tree0904713a3ad28a17305be9dce354ccccd109e90d /var/spack/repos/builtin/packages/py-mxnet
parentef822453b901a0da79516c341d79a4f8e0efdd70 (diff)
downloadspack-9e95e8394e9ddb0e20419688cc6e1d1507b351a1.tar.gz
spack-9e95e8394e9ddb0e20419688cc6e1d1507b351a1.tar.bz2
spack-9e95e8394e9ddb0e20419688cc6e1d1507b351a1.tar.xz
spack-9e95e8394e9ddb0e20419688cc6e1d1507b351a1.zip
Add a package: dmlc/mxnet. (#3579)
* Add dmlc/mxnet packags. * Build mxnet+cuda+opencv with GCC-4.8.5 and GCC-5.4.0. * Build mxnet version 0.10.0, 0.10.0.post1 and 0.10.0.post2. * Add component version constrain for mxnet 0.10.0.x . * Go through flake8. * Replace commit hash with commit date as package version. * Go throught Travis-CI. * Update submodule version for 0.10.0.post2. * Add openmp variant for dmlc-core and mxnet. * Refine variant handling. * Fix filter_file for dmlc-core. * Cut long strings into multiple lies due to PEP8 requirements. * Fix for PEP8. * Add CUB_INCLUDE. * Add py-mxnet: Python binding for MXNet. * Remove distutils.dir_util. * Add the profiler variant for mxnet. * Add a shared variant for nnvm. * Set USE_OPENMP to OFF by default. * Fix flake8 errors. * Fix flake8 issues. * flake8 issues again.
Diffstat (limited to 'var/spack/repos/builtin/packages/py-mxnet')
-rw-r--r--var/spack/repos/builtin/packages/py-mxnet/package.py58
1 files changed, 58 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/py-mxnet/package.py b/var/spack/repos/builtin/packages/py-mxnet/package.py
new file mode 100644
index 0000000000..a733696e46
--- /dev/null
+++ b/var/spack/repos/builtin/packages/py-mxnet/package.py
@@ -0,0 +1,58 @@
+##############################################################################
+# Copyright (c) 2013-2016, Lawrence Livermore National Security, LLC.
+# Produced at the Lawrence Livermore National Laboratory.
+#
+# This file is part of Spack.
+# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
+# LLNL-CODE-647188
+#
+# For details, see https://github.com/llnl/spack
+# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License (as
+# published by the Free Software Foundation) version 2.1, February 1999.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
+# conditions of the GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+##############################################################################
+from spack import *
+
+
+class PyMxnet(PythonPackage):
+ """Python binding for DMLC/MXNet."""
+
+ homepage = "http://mxnet.io"
+ url = "https://github.com/sjtuhpcc/python-mxnet/archive/0.10.0.post2.tar.gz"
+
+ version('0.10.0.post2', '64a646fbf5d1b53ce1008da1bf94d77c',
+ url='https://github.com/sjtuhpcc/python-mxnet/archive/0.10.0.post2.tar.gz')
+
+ # TODO
+ # install_time_test_callbacks = ['install_test', 'import_module_test']
+
+ # import_modules = ['mxnet', 'mxnet.module', 'mxnet._ctypes', 'mxnet.rnn',
+ # 'mxnet._cy2', 'mxnet._cy3', 'mxnet.notebook', 'mxnet.contrib']
+
+ variant('cuda', default=False, description='Enable CUDA support')
+
+ depends_on('python@2.6:2.8,3.3:')
+
+ depends_on('py-setuptools', type=('build', 'run'))
+ depends_on('py-numpy@1.7.1:', type=('build', 'run'))
+ # depends_on('py-pip', type='build')
+
+ depends_on('mxnet', type=('build', 'run'))
+ depends_on('mxnet+cuda', when='+cuda', type=('build', 'run'))
+
+ def patch(self):
+ spec = self.spec
+ filter_file('../../../',
+ spec['mxnet'].prefix.lib,
+ 'mxnet/libinfo.py', string=True)