summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-numpy
diff options
context:
space:
mode:
authorAdam J. Stewart <ajstewart426@gmail.com>2018-08-25 14:12:46 -0500
committerGitHub <noreply@github.com>2018-08-25 14:12:46 -0500
commitcc01e89d6b0a615059fe3c8ac933230ed41930df (patch)
treeedc95e2c3c9e1da7678201e2d733710038f91792 /var/spack/repos/builtin/packages/py-numpy
parent3c292de6bdfe4c058201afe4fdb34cf9a4da8da8 (diff)
downloadspack-cc01e89d6b0a615059fe3c8ac933230ed41930df.tar.gz
spack-cc01e89d6b0a615059fe3c8ac933230ed41930df.tar.bz2
spack-cc01e89d6b0a615059fe3c8ac933230ed41930df.tar.xz
spack-cc01e89d6b0a615059fe3c8ac933230ed41930df.zip
Update to latest version of pytest and dependencies (#9087)
* Update to latest version of pytest and dependencies * Fix bug in installation tests
Diffstat (limited to 'var/spack/repos/builtin/packages/py-numpy')
-rw-r--r--var/spack/repos/builtin/packages/py-numpy/package.py13
1 files changed, 6 insertions, 7 deletions
diff --git a/var/spack/repos/builtin/packages/py-numpy/package.py b/var/spack/repos/builtin/packages/py-numpy/package.py
index 435491f658..7c0dcafbef 100644
--- a/var/spack/repos/builtin/packages/py-numpy/package.py
+++ b/var/spack/repos/builtin/packages/py-numpy/package.py
@@ -34,7 +34,7 @@ class PyNumpy(PythonPackage):
number capabilities"""
homepage = "http://www.numpy.org/"
- url = "https://pypi.io/packages/source/n/numpy/numpy-1.13.1.zip"
+ url = "https://pypi.io/packages/source/n/numpy/numpy-1.15.1.zip"
install_time_test_callbacks = ['install_test', 'import_module_test']
@@ -45,9 +45,7 @@ class PyNumpy(PythonPackage):
'numpy.distutils.command', 'numpy.distutils.fcompiler'
]
- # FIXME: numpy._build_utils and numpy.core.code_generators failed to import
- # FIXME: Is this expected?
-
+ version('1.15.1', '898004d5be091fde59ae353e3008fe9b')
version('1.14.3', '97416212c0a172db4bc6b905e9c4634b')
version('1.14.2', '080f01a19707cf467393e426382c7619')
version('1.14.1', 'b8324ef90ac9064cd0eac46b8b388674')
@@ -67,12 +65,13 @@ class PyNumpy(PythonPackage):
variant('blas', default=True, description='Build with BLAS support')
variant('lapack', default=True, description='Build with LAPACK support')
- depends_on('python@2.7:2.8,3.4:')
+ depends_on('python@2.7:2.8,3.4:', type=('build', 'run'))
depends_on('py-setuptools', type='build')
depends_on('blas', when='+blas')
depends_on('lapack', when='+lapack')
- depends_on('py-nose@1.0.0:', type='test')
+ depends_on('py-nose@1.0.0:', when='@:1.14', type='test')
+ depends_on('py-pytest', when='@1.15:', type='test')
def setup_dependent_package(self, module, dependent_spec):
python_version = self.spec['python'].version.up_to(2)
@@ -182,5 +181,5 @@ class PyNumpy(PythonPackage):
# ImportError: Error importing numpy: you should not try to import
# numpy from its source directory; please exit the numpy
# source tree, and relaunch your python interpreter from there.
- with working_dir('..'):
+ with working_dir('spack-test', create=True):
python('-c', 'import numpy; numpy.test("full", verbose=2)')