summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-pbr/package.py
diff options
context:
space:
mode:
authorJoseph Ciurej <ciurej1@llnl.gov>2016-10-06 14:43:49 -0700
committerTodd Gamblin <tgamblin@llnl.gov>2016-10-06 14:43:49 -0700
commit82fcc5e1deabed8d6774bb13179ee1a4a026400a (patch)
tree4927778d433309bab6915c4da7a5114501e89b8a /var/spack/repos/builtin/packages/py-pbr/package.py
parent415ddeecf8b2038074d90a18f0e956b726beb1a4 (diff)
downloadspack-82fcc5e1deabed8d6774bb13179ee1a4a026400a.tar.gz
spack-82fcc5e1deabed8d6774bb13179ee1a4a026400a.tar.bz2
spack-82fcc5e1deabed8d6774bb13179ee1a4a026400a.tar.xz
spack-82fcc5e1deabed8d6774bb13179ee1a4a026400a.zip
Feature Proposal : Make All Python Extensions User Configuration Independent (#1435)
* Updated all Python extension packages to use 'setup_py' on install. * Fixed a few minor style issues with the updated Python packages.
Diffstat (limited to 'var/spack/repos/builtin/packages/py-pbr/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-pbr/package.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/var/spack/repos/builtin/packages/py-pbr/package.py b/var/spack/repos/builtin/packages/py-pbr/package.py
index a0cfe0e5a5..0251e436b1 100644
--- a/var/spack/repos/builtin/packages/py-pbr/package.py
+++ b/var/spack/repos/builtin/packages/py-pbr/package.py
@@ -38,4 +38,4 @@ class PyPbr(Package):
depends_on('py-setuptools', type='build')
def install(self, spec, prefix):
- python('setup.py', 'install', '--prefix=%s' % prefix)
+ setup_py('install', '--prefix=%s' % prefix)