summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-periodictable/package.py
diff options
context:
space:
mode:
authorTodd Gamblin <tgamblin@llnl.gov>2016-01-17 19:42:28 -0800
committerTodd Gamblin <tgamblin@llnl.gov>2016-01-19 01:16:08 -0800
commit8d6342c53d91f302204d0bbb54f06978a6de26a7 (patch)
tree8848c00c94c5c87bd8c6fb4882e4362920d7096e /var/spack/repos/builtin/packages/py-periodictable/package.py
parentd802165e039a3661831e84ecbdd31f1c4107d39d (diff)
parent97b492756acce93dbd5f1c305504f07df7582ba0 (diff)
downloadspack-8d6342c53d91f302204d0bbb54f06978a6de26a7.tar.gz
spack-8d6342c53d91f302204d0bbb54f06978a6de26a7.tar.bz2
spack-8d6342c53d91f302204d0bbb54f06978a6de26a7.tar.xz
spack-8d6342c53d91f302204d0bbb54f06978a6de26a7.zip
Merge branch 'mplegendre-multi_pkgsrc_roots' into develop
- This moves var/spack/packages to var/spack/repos/builtin/packages. - Packages that did not exist in the source branch, or were changed in develop, were moved into var/spack/repos/builtin/packages as part of the integration. Conflicts: lib/spack/spack/test/unit_install.py var/spack/repos/builtin/packages/clang/package.py
Diffstat (limited to 'var/spack/repos/builtin/packages/py-periodictable/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-periodictable/package.py17
1 files changed, 17 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/py-periodictable/package.py b/var/spack/repos/builtin/packages/py-periodictable/package.py
new file mode 100644
index 0000000000..6a495a1cc8
--- /dev/null
+++ b/var/spack/repos/builtin/packages/py-periodictable/package.py
@@ -0,0 +1,17 @@
+from spack import *
+
+class PyPeriodictable(Package):
+ """nose extends the test loading and running features of unittest,
+ making it easier to write, find and run tests."""
+
+ homepage = "https://pypi.python.org/pypi/periodictable"
+ url = "https://pypi.python.org/packages/source/p/periodictable/periodictable-1.4.1.tar.gz"
+
+ version('1.4.1', '7246b63cc0b6b1be6e86b6616f9e866e')
+
+ depends_on('py-numpy')
+ depends_on('py-pyparsing')
+ extends('python')
+
+ def install(self, spec, prefix):
+ python('setup.py', 'install', '--prefix=%s' % prefix)