summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/py-rpy2/package.py
diff options
context:
space:
mode:
authoralalazo <massimiliano.culpo@googlemail.com>2016-01-28 11:26:01 +0100
committeralalazo <massimiliano.culpo@googlemail.com>2016-01-28 11:26:01 +0100
commite76b722e28eedd94277e5d8ea42beeb5a8d5048e (patch)
tree647b1eb7202d973cadb0bf16bb3797da679cccdd /var/spack/repos/builtin/packages/py-rpy2/package.py
parentbf4231dd4b906f20d522b9df5f2cae2ba6291174 (diff)
parentc2bb00ca2f925c1a8c4b49f7b0a7b22e7c0b43a8 (diff)
downloadspack-e76b722e28eedd94277e5d8ea42beeb5a8d5048e.tar.gz
spack-e76b722e28eedd94277e5d8ea42beeb5a8d5048e.tar.bz2
spack-e76b722e28eedd94277e5d8ea42beeb5a8d5048e.tar.xz
spack-e76b722e28eedd94277e5d8ea42beeb5a8d5048e.zip
Merge branch 'develop' of https://github.com/LLNL/spack into enhancement/os_detection
Diffstat (limited to 'var/spack/repos/builtin/packages/py-rpy2/package.py')
-rw-r--r--var/spack/repos/builtin/packages/py-rpy2/package.py17
1 files changed, 17 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/py-rpy2/package.py b/var/spack/repos/builtin/packages/py-rpy2/package.py
new file mode 100644
index 0000000000..a0b03d03e3
--- /dev/null
+++ b/var/spack/repos/builtin/packages/py-rpy2/package.py
@@ -0,0 +1,17 @@
+from spack import *
+
+class PyRpy2(Package):
+ """rpy2 is a redesign and rewrite of rpy. It is providing a low-level interface to R from Python, a proposed high-level interface, including wrappers to graphical libraries, as well as R-like structures and functions."""
+ homepage = "https://pypi.python.org/pypi/rpy2"
+ url = "https://pypi.python.org/packages/source/r/rpy2/rpy2-2.5.4.tar.gz"
+
+ version('2.5.4', '115a20ac30883f096da2bdfcab55196d')
+ version('2.5.6', 'a36e758b633ce6aec6a5f450bfee980f')
+
+ extends('python')
+ depends_on('py-setuptools')
+
+ depends_on('R')
+
+ def install(self, spec, prefix):
+ python('setup.py', 'install', '--prefix=%s' % prefix)