summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/rankstr/package.py
diff options
context:
space:
mode:
authorElsa Gonsiorowski, PhD <gonsie@me.com>2018-07-07 16:56:56 +0200
committerAdam J. Stewart <ajstewart426@gmail.com>2018-07-07 09:56:56 -0500
commitc907937ff48d2c5f004061a0caf4fe61452ca8c6 (patch)
treed8d1618ead3f5e63309609d780bc2a5ec54ac7f7 /var/spack/repos/builtin/packages/rankstr/package.py
parent891aa6ad7ae243154da9af2fbcd88f175d4dc047 (diff)
downloadspack-c907937ff48d2c5f004061a0caf4fe61452ca8c6.tar.gz
spack-c907937ff48d2c5f004061a0caf4fe61452ca8c6.tar.bz2
spack-c907937ff48d2c5f004061a0caf4fe61452ca8c6.tar.xz
spack-c907937ff48d2c5f004061a0caf4fe61452ca8c6.zip
ECP VELOC (#8581)
* kvtree package file * MPI is default on * proper mpi compiler * rankstr package * better rankstr description * typo * redset package * shuffile package * er package * axl package * proper pythor * mpi is default on * alpha releases and master versions * veloc package with boost headers dep * cmake version * added C++11 requirement * flake8 * flake8 * ecp tag * axl: better async api option handling * veloc package description * prettier args list * C++11 flag handler * v1.0 of veloc
Diffstat (limited to 'var/spack/repos/builtin/packages/rankstr/package.py')
-rw-r--r--var/spack/repos/builtin/packages/rankstr/package.py46
1 files changed, 46 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/rankstr/package.py b/var/spack/repos/builtin/packages/rankstr/package.py
new file mode 100644
index 0000000000..88963be60b
--- /dev/null
+++ b/var/spack/repos/builtin/packages/rankstr/package.py
@@ -0,0 +1,46 @@
+##############################################################################
+# Copyright (c) 2013-2018, Lawrence Livermore National Security, LLC.
+# Produced at the Lawrence Livermore National Laboratory.
+#
+# This file is part of Spack.
+# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
+# LLNL-CODE-647188
+#
+# For details, see https://github.com/spack/spack
+# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License (as
+# published by the Free Software Foundation) version 2.1, February 1999.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
+# conditions of the GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+##############################################################################
+from spack import *
+
+
+class Rankstr(CMakePackage):
+ """Assign one-to-one mapping of MPI ranks to strings"""
+
+ homepage = "https://github.com/ECP-VeloC/rankstr"
+ url = "https://github.com/ECP-VeloC/rankstr/archive/v0.0.1.zip"
+ tags = ['ecp']
+
+ version('0.0.1', 'abe06fa6a78cfe20ec0c78717ac2f2ed')
+ version('master', git='https://github.com/ecp-veloc/rankstr.git',
+ branch='master')
+
+ depends_on('mpi')
+
+ def cmake_args(self):
+ args = []
+ args.append("-DMPI_C_COMPILER=%s" % self.spec['mpi'].mpicc)
+ if self.spec.satisfies('platform=cray'):
+ args.append("-DRANKSTR_LINK_STATIC=ON")
+ return args