summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/tealeaf/package.py
diff options
context:
space:
mode:
authorTodd Gamblin <tgamblin@llnl.gov>2022-07-30 15:19:18 -0700
committerTodd Gamblin <tgamblin@llnl.gov>2022-07-31 13:29:20 -0700
commitf52f6e99dbf1131886a80112b8c79dfc414afb7c (patch)
tree05cb7d64b2395922f2f24683da49f472075be12c /var/spack/repos/builtin/packages/tealeaf/package.py
parent549ba1ed32372c67fc57271cde3797d58b7dec6e (diff)
downloadspack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.gz
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.bz2
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.tar.xz
spack-f52f6e99dbf1131886a80112b8c79dfc414afb7c.zip
black: reformat entire repository with black
Diffstat (limited to 'var/spack/repos/builtin/packages/tealeaf/package.py')
-rw-r--r--var/spack/repos/builtin/packages/tealeaf/package.py48
1 files changed, 24 insertions, 24 deletions
diff --git a/var/spack/repos/builtin/packages/tealeaf/package.py b/var/spack/repos/builtin/packages/tealeaf/package.py
index 555f2933f6..da8b351b51 100644
--- a/var/spack/repos/builtin/packages/tealeaf/package.py
+++ b/var/spack/repos/builtin/packages/tealeaf/package.py
@@ -11,40 +11,40 @@ from spack.package import *
class Tealeaf(MakefilePackage):
"""Proxy Application. TeaLeaf is a mini-app that solves
- the linear heat conduction equation on a spatially decomposed
- regularly grid using a 5 point stencil with implicit solvers.
+ the linear heat conduction equation on a spatially decomposed
+ regularly grid using a 5 point stencil with implicit solvers.
"""
homepage = "https://uk-mac.github.io/TeaLeaf/"
- url = "https://downloads.mantevo.org/releaseTarballs/miniapps/TeaLeaf/TeaLeaf-1.0.tar.gz"
+ url = "https://downloads.mantevo.org/releaseTarballs/miniapps/TeaLeaf/TeaLeaf-1.0.tar.gz"
- tags = ['proxy-app']
+ tags = ["proxy-app"]
- version('1.0', sha256='e11799d1a3fbe76041333ba98858043b225c5d65221df8c600479bc55e7197ce')
+ version("1.0", sha256="e11799d1a3fbe76041333ba98858043b225c5d65221df8c600479bc55e7197ce")
- depends_on('mpi')
+ depends_on("mpi")
def edit(self, spec, prefix):
- filter_file('-march=native', '', join_path('TeaLeaf_ref', 'Makefile'))
+ filter_file("-march=native", "", join_path("TeaLeaf_ref", "Makefile"))
@property
def build_targets(self):
targets = [
- '--directory=TeaLeaf_ref',
- 'MPI_COMPILER={0}'.format(self.spec['mpi'].mpifc),
- 'C_MPI_COMPILER={0}'.format(self.spec['mpi'].mpicc),
+ "--directory=TeaLeaf_ref",
+ "MPI_COMPILER={0}".format(self.spec["mpi"].mpifc),
+ "C_MPI_COMPILER={0}".format(self.spec["mpi"].mpicc),
]
- if '%gcc' in self.spec:
- targets.append('COMPILER=GNU')
- elif '%cce' in self.spec:
- targets.append('COMPILER=CRAY')
- elif '%intel' in self.spec:
- targets.append('COMPILER=INTEL')
- elif '%pgi' in self.spec:
- targets.append('COMPILER=PGI')
- elif '%xl' in self.spec:
- targets.append('COMPILER=XL')
+ if "%gcc" in self.spec:
+ targets.append("COMPILER=GNU")
+ elif "%cce" in self.spec:
+ targets.append("COMPILER=CRAY")
+ elif "%intel" in self.spec:
+ targets.append("COMPILER=INTEL")
+ elif "%pgi" in self.spec:
+ targets.append("COMPILER=PGI")
+ elif "%xl" in self.spec:
+ targets.append("COMPILER=XL")
return targets
@@ -53,9 +53,9 @@ class Tealeaf(MakefilePackage):
mkdirp(prefix.bin)
mkdirp(prefix.doc.tests)
- install('README.md', prefix.doc)
- install('TeaLeaf_ref/tea_leaf', prefix.bin)
- install('TeaLeaf_ref/tea.in', prefix.bin)
+ install("README.md", prefix.doc)
+ install("TeaLeaf_ref/tea_leaf", prefix.bin)
+ install("TeaLeaf_ref/tea.in", prefix.bin)
- for f in glob.glob('TeaLeaf_ref/*.in'):
+ for f in glob.glob("TeaLeaf_ref/*.in"):
install(f, prefix.doc.tests)