summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/tinyxml/package.py
diff options
context:
space:
mode:
authorMayeul d'Avezac <m.davezac@ucl.ac.uk>2016-12-27 08:32:29 +0000
committerTodd Gamblin <tgamblin@llnl.gov>2016-12-27 00:32:29 -0800
commit81c1404b9cd071d1433852bd0b05fb168a53f981 (patch)
treeb6793d6c7eb84a59710438c78679419e66da014b /var/spack/repos/builtin/packages/tinyxml/package.py
parentbaaa613e445f8a00baf22efe61e8e16a3ee87591 (diff)
downloadspack-81c1404b9cd071d1433852bd0b05fb168a53f981.tar.gz
spack-81c1404b9cd071d1433852bd0b05fb168a53f981.tar.bz2
spack-81c1404b9cd071d1433852bd0b05fb168a53f981.tar.xz
spack-81c1404b9cd071d1433852bd0b05fb168a53f981.zip
Adds catch, cppunit, spdlog, tinyxml(1 and 2), google benchmark (#2627)
* Adds catch, cppunit, spdlog, tinyxml(1 and 2), google benchmark Tinyxml comes in two flavors, 1 and 2. Each comes in several versions... So they cannot be easily united into a single package. * Use CMakePackage and friends, add copyright Also eleminate debug/release variants, since it no longuer fits in the CMakePackage format. * Remove unnecessary url * spdlog now has tagged releases * Remove unnecessary url argument * Fewer quotes in cmake args, because magic * Incorrect base class for tinyxml
Diffstat (limited to 'var/spack/repos/builtin/packages/tinyxml/package.py')
-rw-r--r--var/spack/repos/builtin/packages/tinyxml/package.py39
1 files changed, 39 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/tinyxml/package.py b/var/spack/repos/builtin/packages/tinyxml/package.py
new file mode 100644
index 0000000000..1789d9022e
--- /dev/null
+++ b/var/spack/repos/builtin/packages/tinyxml/package.py
@@ -0,0 +1,39 @@
+##############################################################################
+# Copyright (c) 2013-2016, Lawrence Livermore National Security, LLC.
+# Produced at the Lawrence Livermore National Laboratory.
+#
+# This file is part of Spack.
+# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
+# LLNL-CODE-647188
+#
+# For details, see https://github.com/llnl/spack
+# Please also see the LICENSE file for our notice and the LGPL.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License (as
+# published by the Free Software Foundation) version 2.1, February 1999.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
+# conditions of the GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+##############################################################################
+from spack import *
+import os.path
+
+
+class Tinyxml(CMakePackage):
+ """Simple, small, efficient, C++ XML parser"""
+
+ homepage = "http://grinninglizard.com/tinyxml/"
+ url = "https://sourceforge.net/projects/tinyxml/files/tinyxml/2.6.2/tinyxml_2_6_2.tar.gz"
+
+ version('2.6.2', 'cba3f50dd657cb1434674a03b21394df9913d764')
+
+ def patch(self):
+ copyfile(join_path(os.path.dirname(__file__),
+ "CMakeLists.txt"), "CMakeLists.txt")