summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/tinyxml/package.py
diff options
context:
space:
mode:
authorTodd Gamblin <tgamblin@llnl.gov>2017-01-17 01:36:03 -0800
committerTodd Gamblin <tgamblin@llnl.gov>2017-01-17 01:36:03 -0800
commit52a9e5d2a31b4a66ce51d0ff03ab709417dee6dc (patch)
treeef8216231785feaf7ee3f2d037f4240bdd115be8 /var/spack/repos/builtin/packages/tinyxml/package.py
parent4f8167b7ed8fe156e1f350aaa37230ab07a27895 (diff)
parent18563177775509286e5b53744ea5924bc450d9c2 (diff)
downloadspack-52a9e5d2a31b4a66ce51d0ff03ab709417dee6dc.tar.gz
spack-52a9e5d2a31b4a66ce51d0ff03ab709417dee6dc.tar.bz2
spack-52a9e5d2a31b4a66ce51d0ff03ab709417dee6dc.tar.xz
spack-52a9e5d2a31b4a66ce51d0ff03ab709417dee6dc.zip
Merge branch 'releases/v0.10.0'v0.10.0
Diffstat (limited to 'var/spack/repos/builtin/packages/tinyxml/package.py')
-rw-r--r--var/spack/repos/builtin/packages/tinyxml/package.py39
1 files changed, 39 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/tinyxml/package.py b/var/spack/repos/builtin/packages/tinyxml/package.py
new file mode 100644
index 0000000000..1789d9022e
--- /dev/null
+++ b/var/spack/repos/builtin/packages/tinyxml/package.py
@@ -0,0 +1,39 @@
+##############################################################################
+# Copyright (c) 2013-2016, Lawrence Livermore National Security, LLC.
+# Produced at the Lawrence Livermore National Laboratory.
+#
+# This file is part of Spack.
+# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
+# LLNL-CODE-647188
+#
+# For details, see https://github.com/llnl/spack
+# Please also see the LICENSE file for our notice and the LGPL.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License (as
+# published by the Free Software Foundation) version 2.1, February 1999.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
+# conditions of the GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+##############################################################################
+from spack import *
+import os.path
+
+
+class Tinyxml(CMakePackage):
+ """Simple, small, efficient, C++ XML parser"""
+
+ homepage = "http://grinninglizard.com/tinyxml/"
+ url = "https://sourceforge.net/projects/tinyxml/files/tinyxml/2.6.2/tinyxml_2_6_2.tar.gz"
+
+ version('2.6.2', 'cba3f50dd657cb1434674a03b21394df9913d764')
+
+ def patch(self):
+ copyfile(join_path(os.path.dirname(__file__),
+ "CMakeLists.txt"), "CMakeLists.txt")