summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml71
1 files changed, 71 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index f5fed2df4b..30b621dec4 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,3 +1,74 @@
+[project]
+name="spack"
+description="The spack package manager"
+dependencies=[
+ "clingo",
+ "setuptools",
+ "six",
+ "types-six",
+]
+dynamic = ["version"]
+
+[project.scripts]
+spack = "lib.spack.spack_installable.main:main"
+
+[tool.hatch.version]
+path = "lib/spack/spack/__init__.py"
+
+[project.optional-dependencies]
+dev = [
+ "pip>=21.3",
+ "pytest",
+ "pytest-xdist",
+ "setuptools",
+ "click==8.0.2",
+ 'black==21.12b0',
+ "mypy",
+ "isort",
+ "flake8",
+ "vermin",
+]
+ci = [
+ "pytest-cov",
+ "codecov[toml]",
+]
+
+[build-system]
+requires = ["hatchling"]
+build-backend = "hatchling.build"
+
+[tool.hatch.build.targets.wheel]
+include = [
+ "/bin",
+ "/etc",
+ "/lib",
+ "/share",
+ "/var",
+ "CITATION.cff",
+ "COPYRIGHT",
+ "LICENSE-APACHE",
+ "LICENSE-MIT",
+ "NOTICE",
+ "README.md",
+ "SECURITY.md",
+]
+
+[tool.hatch.envs.default]
+features = [
+ "dev",
+]
+
+[tool.hatch.envs.default.scripts]
+spack = "./bin/spack"
+style = "./bin/spack style"
+test = "./bin/spack unit-test"
+
+[tool.hatch.envs.ci]
+features = [
+ "dev",
+ "ci",
+]
+
[tool.black]
line-length = 99
target-version = ['py27', 'py35', 'py36', 'py37', 'py38', 'py39', 'py310']