summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/adlbx/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/adlbx/package.py')
-rw-r--r--var/spack/repos/builtin/packages/adlbx/package.py40
1 files changed, 15 insertions, 25 deletions
diff --git a/var/spack/repos/builtin/packages/adlbx/package.py b/var/spack/repos/builtin/packages/adlbx/package.py
index dfe6dffb03..4f7e06d2c9 100644
--- a/var/spack/repos/builtin/packages/adlbx/package.py
+++ b/var/spack/repos/builtin/packages/adlbx/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -30,12 +11,21 @@ class Adlbx(AutotoolsPackage):
"""ADLB/X: Master-worker library + work stealing and data dependencies"""
homepage = 'http://swift-lang.org/Swift-T'
- url = 'http://swift-lang.github.io/swift-t-downloads/adlbx-0.8.0.tar.gz'
+ url = 'http://swift-lang.github.io/swift-t-downloads/spack/adlbx-0.0.0.tar.gz'
+
+ version('0.9.1', '07151ddef5fb83d8f4b40700013d9daf')
version('0.8.0', '34ade59ce3be5bc296955231d47a27dd')
- depends_on('exmcutils')
+ depends_on('exmcutils@:0.5.3', when='@:0.8.0')
+ depends_on('exmcutils', when='@0.9.1:')
depends_on('mpi')
+ def setup_environment(self, spack_env, run_env):
+ spec = self.spec
+ spack_env.set('CC', spec['mpi'].mpicc)
+ spack_env.set('CXX', spec['mpi'].mpicxx)
+ spack_env.set('CXXLD', spec['mpi'].mpicxx)
+
def configure_args(self):
args = ['--with-c-utils=' + self.spec['exmcutils'].prefix]
return args