summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/amrfinder/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/amrfinder/package.py')
-rw-r--r--var/spack/repos/builtin/packages/amrfinder/package.py28
1 files changed, 14 insertions, 14 deletions
diff --git a/var/spack/repos/builtin/packages/amrfinder/package.py b/var/spack/repos/builtin/packages/amrfinder/package.py
index ce7278293d..32cce65ab1 100644
--- a/var/spack/repos/builtin/packages/amrfinder/package.py
+++ b/var/spack/repos/builtin/packages/amrfinder/package.py
@@ -9,27 +9,27 @@ from spack.package import *
class Amrfinder(MakefilePackage):
"""NCBI AMRFinderPlus: This software and the accompanying database identify
- acquired antimicrobial resistance genes in bacterial protein and/or
- assembled nucleotide sequences as well as known resistance-associated
- point mutations for several taxa. With AMRFinderPlus we added select
- members of additional classes of genes such as virulence factors,
- biocide, heat, acid, and metal resistance genes."""
+ acquired antimicrobial resistance genes in bacterial protein and/or
+ assembled nucleotide sequences as well as known resistance-associated
+ point mutations for several taxa. With AMRFinderPlus we added select
+ members of additional classes of genes such as virulence factors,
+ biocide, heat, acid, and metal resistance genes."""
homepage = "https://github.com/ncbi/amr/wiki"
- url = "https://github.com/ncbi/amr/archive/refs/tags/amrfinder_v3.10.30.tar.gz"
+ url = "https://github.com/ncbi/amr/archive/refs/tags/amrfinder_v3.10.30.tar.gz"
- version('3.10.30', sha256='2f1e30b86935a27cee740bd7229a41fbce278f2f60b33b8e51592bab8bdf23f1')
- version('3.10.24', sha256='fce299c980cda740dcc4f53f9b2dc9061c856213e5bdbc2c339185a5fb7dcf6a')
+ version("3.10.30", sha256="2f1e30b86935a27cee740bd7229a41fbce278f2f60b33b8e51592bab8bdf23f1")
+ version("3.10.24", sha256="fce299c980cda740dcc4f53f9b2dc9061c856213e5bdbc2c339185a5fb7dcf6a")
- depends_on('blast-plus')
- depends_on('hmmer')
- depends_on('curl')
+ depends_on("blast-plus")
+ depends_on("hmmer")
+ depends_on("curl")
def setup_build_environment(self, env):
- env.set('INSTALL_DIR', prefix.bin)
- env.set('DEFAULT_DB_DIR', prefix.share)
+ env.set("INSTALL_DIR", prefix.bin)
+ env.set("DEFAULT_DB_DIR", prefix.share)
- @run_before('build')
+ @run_before("build")
def create_bin_and_share(self):
mkdirp(self.spec.prefix.bin)
mkdirp(self.spec.prefix.share)