summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/ascent/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/ascent/package.py')
-rw-r--r--var/spack/repos/builtin/packages/ascent/package.py14
1 files changed, 9 insertions, 5 deletions
diff --git a/var/spack/repos/builtin/packages/ascent/package.py b/var/spack/repos/builtin/packages/ascent/package.py
index eda0f93c1c..9cf1f4a7a5 100644
--- a/var/spack/repos/builtin/packages/ascent/package.py
+++ b/var/spack/repos/builtin/packages/ascent/package.py
@@ -97,9 +97,7 @@ class Ascent(Package):
# causes duplicate state issues when running compiled python modules.
depends_on("python+shared")
extends("python", when="+python")
- # TODO: blas and lapack are disabled due to build
- # issues Cyrus experienced on OSX 10.11.6
- depends_on("py-numpy~blas~lapack", when="+python", type=('build', 'run'))
+ depends_on("py-numpy", when="+python", type=('build', 'run'))
#######################
# MPI
@@ -298,8 +296,14 @@ class Ascent(Package):
spec['mpi'].mpifc))
mpiexe_bin = join_path(spec['mpi'].prefix.bin, 'mpiexec')
if os.path.isfile(mpiexe_bin):
- cfg.write(cmake_cache_entry("MPIEXEC",
- mpiexe_bin))
+ # starting with cmake 3.10, FindMPI expects MPIEXEC_EXECUTABLE
+ # vs the older versions which expect MPIEXEC
+ if self.spec["cmake"].satisfies('@3.10:'):
+ cfg.write(cmake_cache_entry("MPIEXEC_EXECUTABLE",
+ mpiexe_bin))
+ else:
+ cfg.write(cmake_cache_entry("MPIEXEC",
+ mpiexe_bin))
else:
cfg.write(cmake_cache_entry("ENABLE_MPI", "OFF"))