summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/assimp/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/assimp/package.py')
-rw-r--r--var/spack/repos/builtin/packages/assimp/package.py44
1 files changed, 19 insertions, 25 deletions
diff --git a/var/spack/repos/builtin/packages/assimp/package.py b/var/spack/repos/builtin/packages/assimp/package.py
index dd9b414772..3852df5bc4 100644
--- a/var/spack/repos/builtin/packages/assimp/package.py
+++ b/var/spack/repos/builtin/packages/assimp/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -30,12 +11,25 @@ class Assimp(CMakePackage):
import various well-known 3D model formats in a uniform manner."""
homepage = "https://www.assimp.org"
- url = "https://github.com/assimp/assimp/archive/v3.3.1.tar.gz"
+ url = "https://github.com/assimp/assimp/archive/v4.0.1.tar.gz"
version('4.0.1', '23a6301c728a413aafbfa1cca19ba91f')
+ variant('shared', default=True,
+ description='Enables the build of shared libraries')
+
depends_on('boost')
def cmake_args(self):
- args = ['-DASSIMP_BUILD_TESTS=OFF']
+ args = [
+ '-DASSIMP_BUILD_TESTS=OFF',
+ '-DBUILD_SHARED_LIBS:BOOL=%s' % (
+ 'ON' if '+shared' in self.spec else 'OFF'),
+ ]
return args
+
+ def flag_handler(self, name, flags):
+ flags = list(flags)
+ if name == 'cxxflags':
+ flags.append(self.compiler.cxx11_flag)
+ return (None, None, flags)