summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/atmi/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/atmi/package.py')
-rw-r--r--var/spack/repos/builtin/packages/atmi/package.py42
1 files changed, 42 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/atmi/package.py b/var/spack/repos/builtin/packages/atmi/package.py
new file mode 100644
index 0000000000..c6063b3fde
--- /dev/null
+++ b/var/spack/repos/builtin/packages/atmi/package.py
@@ -0,0 +1,42 @@
+# Copyright 2013-2020 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
+#
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
+
+from spack import *
+
+
+class Atmi(CMakePackage):
+ """Asynchronous Task and Memory Interface, or ATMI, is a runtime framework
+ and programming model for heterogeneous CPU-GPU systems. It provides a
+ consistent, declarative API to create task graphs on CPUs and GPUs
+ (integrated and discrete)."""
+
+ homepage = "https://github.com/RadeonOpenCompute/atmi"
+ url = "https://github.com/RadeonOpenCompute/atmi/archive/rocm-3.5.0.tar.gz"
+
+ maintainers = ['srekolam', 'arjun-raj-kuppala']
+
+ version('3.5.0', sha256='3fb57d2e583fab82bd0582d0c2bccff059ca91122c18ac49a7770a8bb041a37b')
+
+ variant('build_type', default='Release', values=("Release", "Debug"), description='CMake build type')
+ depends_on('cmake@3:', type='build')
+ depends_on('libelf@0.8:', type='link', when='@3.5:')
+
+ for ver in ['3.5.0']:
+ depends_on('comgr@' + ver, type='link', when='@' + ver)
+ depends_on('hsa-rocr-dev@' + ver, type='link', when='@' + ver)
+
+ root_cmakelists_dir = 'src'
+
+ patch('0001-Remove-relative-link-paths-to-external-libraries.patch')
+
+ def cmake_args(self):
+ return [
+ '-DROCM_VERSION={0}'.format(self.spec.version)
+ ]
+
+ @run_after('install')
+ def install_stub(self):
+ install('include/atmi_interop_hsa.h', self.prefix.include)