summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/autodock-vina/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/autodock-vina/package.py')
-rw-r--r--var/spack/repos/builtin/packages/autodock-vina/package.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/var/spack/repos/builtin/packages/autodock-vina/package.py b/var/spack/repos/builtin/packages/autodock-vina/package.py
index dadf50ea05..8ca01804d8 100644
--- a/var/spack/repos/builtin/packages/autodock-vina/package.py
+++ b/var/spack/repos/builtin/packages/autodock-vina/package.py
@@ -44,10 +44,10 @@ class AutodockVina(MakefilePackage):
with working_dir(self.build_directory):
makefile = FileFilter("Makefile")
makefile.filter(
- "BOOST_INCLUDE = .*", "BOOST_INCLUDE = %s" % self.spec["boost"].prefix.include
+ "BOOST_INCLUDE = .*", f"BOOST_INCLUDE = {self.spec['boost'].prefix.include}"
)
makefile.filter("C_PLATFORM=.*", "C_PLATFORM=-pthread")
- makefile.filter("GPP=.*", "GPP=%s" % spack_cxx)
+ makefile.filter("GPP=.*", f"GPP={spack_cxx}")
def build(self, spec, prefix):
with working_dir(self.build_directory):