summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/boost/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/boost/package.py')
-rw-r--r--var/spack/repos/builtin/packages/boost/package.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/boost/package.py b/var/spack/repos/builtin/packages/boost/package.py
index 411e20596b..2b6e587b57 100644
--- a/var/spack/repos/builtin/packages/boost/package.py
+++ b/var/spack/repos/builtin/packages/boost/package.py
@@ -277,6 +277,11 @@ class Boost(Package):
# and https://github.com/spack/spack/pull/21408
patch("bootstrap-toolset.patch", when="@1.75")
+ # Allow building context asm sources with GCC on Darwin
+ # See https://github.com/spack/spack/pull/24889
+ # and https://github.com/boostorg/context/issues/177
+ patch("context-macho-gcc.patch", when="+context platform=darwin %gcc")
+
def patch(self):
# Disable SSSE3 and AVX2 when using the NVIDIA compiler
if self.spec.satisfies('%nvhpc'):