summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/bzip2/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/bzip2/package.py')
-rw-r--r--var/spack/repos/builtin/packages/bzip2/package.py45
1 files changed, 16 insertions, 29 deletions
diff --git a/var/spack/repos/builtin/packages/bzip2/package.py b/var/spack/repos/builtin/packages/bzip2/package.py
index d44e97207f..2f89b73b8e 100644
--- a/var/spack/repos/builtin/packages/bzip2/package.py
+++ b/var/spack/repos/builtin/packages/bzip2/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -32,27 +13,33 @@ class Bzip2(Package):
compressors), whilst being around twice as fast at compression
and six times faster at decompression."""
- homepage = "http://www.bzip.org"
- url = "http://www.bzip.org/1.0.6/bzip2-1.0.6.tar.gz"
- list_url = "http://www.bzip.org/downloads.html"
+ # FIXME: The bzip.org domain has expired:
+ # https://lwn.net/Articles/762264/
+ # This package will need to be updated when a new home is found.
+ homepage = "https://sourceware.org/bzip2/"
+ url = "https://fossies.org/linux/misc/bzip2-1.0.6.tar.gz"
version('1.0.6', '00b516f4704d4a7cb50a1d97e6e8e15b')
variant('shared', default=True, description='Enables the build of shared libraries.')
+ depends_on('diffutils', type='build')
+
# override default implementation
@property
def libs(self):
shared = '+shared' in self.spec
return find_libraries(
- 'libbz2', root=self.prefix, shared=shared, recurse=True
+ 'libbz2', root=self.prefix, shared=shared, recursive=True
)
def patch(self):
# bzip2 comes with two separate Makefiles for static and dynamic builds
# Tell both to use Spack's compiler wrapper instead of GCC
- filter_file(r'^CC=gcc', 'CC=cc', 'Makefile')
- filter_file(r'^CC=gcc', 'CC=cc', 'Makefile-libbz2_so')
+ filter_file(r'^CC=gcc', 'CC={0}'.format(spack_cc), 'Makefile')
+ filter_file(
+ r'^CC=gcc', 'CC={0}'.format(spack_cc), 'Makefile-libbz2_so'
+ )
# The Makefiles use GCC flags that are incompatible with PGI
if self.compiler.name == 'pgi':