summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/ca-certificates-mozilla/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/ca-certificates-mozilla/package.py')
-rw-r--r--var/spack/repos/builtin/packages/ca-certificates-mozilla/package.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/var/spack/repos/builtin/packages/ca-certificates-mozilla/package.py b/var/spack/repos/builtin/packages/ca-certificates-mozilla/package.py
index b49ef03cf7..d828d4c5a8 100644
--- a/var/spack/repos/builtin/packages/ca-certificates-mozilla/package.py
+++ b/var/spack/repos/builtin/packages/ca-certificates-mozilla/package.py
@@ -31,9 +31,13 @@ class CaCertificatesMozilla(Package):
def url_for_version(self, version):
return "https://curl.se/ca/cacert-{0}.pem".format(version)
+ def setup_dependent_package(self, module, dep_spec):
+ """Returns the absolute path to the bundled certificates"""
+ self.spec.pem_path = join_path(self.prefix.share, 'cacert.pem')
+
# Install the the pem file as share/cacert.pem
def install(self, spec, prefix):
- share = join_path(self.prefix, 'share')
+ share = join_path(prefix, 'share')
mkdir(share)
install("cacert-{0}.pem".format(spec.version),
join_path(share, "cacert.pem"))