summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/canu/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/canu/package.py')
-rw-r--r--var/spack/repos/builtin/packages/canu/package.py14
1 files changed, 3 insertions, 11 deletions
diff --git a/var/spack/repos/builtin/packages/canu/package.py b/var/spack/repos/builtin/packages/canu/package.py
index 2b99fe63fc..1aec3384df 100644
--- a/var/spack/repos/builtin/packages/canu/package.py
+++ b/var/spack/repos/builtin/packages/canu/package.py
@@ -21,6 +21,7 @@ class Canu(MakefilePackage):
depends_on('perl', type='run')
build_directory = 'src'
+ build_targets = ['clean']
def patch(self):
# Use our perl, not whatever is in the environment
@@ -29,14 +30,5 @@ class Canu(MakefilePackage):
'src/pipelines/canu.pl')
def install(self, spec, prefix):
- # replicate the Makefile logic here:
- # https://github.com/marbl/canu/blob/master/src/Makefile#L344
- uname = which('uname')
- ostype = uname(output=str).strip()
- machinetype = uname('-m', output=str).strip()
- if machinetype == 'x86_64':
- machinetype = 'amd64'
- target_dir = '{0}-{1}'.format(ostype, machinetype)
- bin = join_path(target_dir, 'bin')
-
- install_tree(bin, prefix.bin)
+ with working_dir(self.build_directory):
+ make('all', 'TARGET_DIR={0}'.format(prefix))