summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/casper/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/casper/package.py')
-rw-r--r--var/spack/repos/builtin/packages/casper/package.py49
1 files changed, 49 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/casper/package.py b/var/spack/repos/builtin/packages/casper/package.py
new file mode 100644
index 0000000000..170bdaecef
--- /dev/null
+++ b/var/spack/repos/builtin/packages/casper/package.py
@@ -0,0 +1,49 @@
+##############################################################################
+# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
+# Produced at the Lawrence Livermore National Laboratory.
+#
+# This file is part of Spack.
+# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
+# LLNL-CODE-647188
+#
+# For details, see https://github.com/spack/spack
+# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License (as
+# published by the Free Software Foundation) version 2.1, February 1999.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
+# conditions of the GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+##############################################################################
+from spack import *
+import distutils.dir_util
+
+
+class Casper(MakefilePackage):
+ """CASPER (Context-Aware Scheme for Paired-End Read) is state-of-the art
+ merging tool in terms of accuracy and robustness. Using this
+ sophisticated merging method, we could get elongated reads from the
+ forward and reverse reads."""
+
+ homepage = "http://best.snu.ac.kr/casper/index.php?name=main"
+ url = "http://best.snu.ac.kr/casper/program/casper_v0.8.2.tar.gz"
+
+ version('0.8.2', '9e83d32ff46b876f33eb1d7b545ec9c2')
+
+ depends_on('jellyfish@2.2.3:')
+ depends_on('boost')
+
+ conflicts('%gcc@7.1.0')
+
+ def install(self, spec, prefix):
+ distutils.dir_util.copy_tree(".", prefix)
+
+ def setup_environment(self, spack_env, run_env):
+ run_env.prepend_path('PATH', self.spec.prefix)