summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/cbench/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/cbench/package.py')
-rw-r--r--var/spack/repos/builtin/packages/cbench/package.py45
1 files changed, 13 insertions, 32 deletions
diff --git a/var/spack/repos/builtin/packages/cbench/package.py b/var/spack/repos/builtin/packages/cbench/package.py
index c090907af7..d7bd1a7eb7 100644
--- a/var/spack/repos/builtin/packages/cbench/package.py
+++ b/var/spack/repos/builtin/packages/cbench/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -50,27 +31,27 @@ class Cbench(MakefilePackage):
conflicts('%xl')
conflicts('%xl_r')
- def edit(self, spec, prefix):
+ def setup_environment(self, build_env, run_env):
# The location of the Cbench source tree
- env['CBENCHOME'] = self.stage.source_path
+ build_env.set('CBENCHOME', self.stage.source_path)
# The location that will contain all of your tests and their results
- env['CBENCHTEST'] = prefix
+ build_env.set('CBENCHTEST', self.prefix)
# The location of the system MPI tree
- env['MPIHOME'] = spec['mpi'].prefix
+ build_env.set('MPIHOME', self.spec['mpi'].prefix)
# Pick the compiler collection/chain you want to compile with.
# Examples include: intel, gcc, pgi.
- env['COMPILERCOLLECTION'] = self.compiler.name
+ build_env.set('COMPILERCOLLECTION', self.compiler.name)
# Linking flags for BLAS/LAPACK and FFTW
- env['BLASLIB'] = spec['blas'].libs.ld_flags
- env['LAPACKLIB'] = spec['lapack'].libs.ld_flags
- env['FFTWLIB'] = spec['fftw'].libs.ld_flags
+ build_env.set('BLASLIB', self.spec['blas'].libs.ld_flags)
+ build_env.set('LAPACKLIB', self.spec['lapack'].libs.ld_flags)
+ build_env.set('FFTWLIB', self.spec['fftw'].libs.ld_flags)
# The number of make jobs (commands) to run simultaneously
- env['JOBS'] = str(make_jobs)
+ build_env.set('JOBS', str(make_jobs))
@run_before('build')
@on_package_attributes(run_tests=True)