summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/cblas/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/cblas/package.py')
-rw-r--r--var/spack/repos/builtin/packages/cblas/package.py39
1 files changed, 10 insertions, 29 deletions
diff --git a/var/spack/repos/builtin/packages/cblas/package.py b/var/spack/repos/builtin/packages/cblas/package.py
index 05a3ddb43e..3a36664103 100644
--- a/var/spack/repos/builtin/packages/cblas/package.py
+++ b/var/spack/repos/builtin/packages/cblas/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -42,10 +23,10 @@ class Cblas(Package):
def patch(self):
mf = FileFilter('Makefile.in')
- mf.filter('^BLLIB =.*', 'BLLIB = %s/libblas.a' %
- self.spec['blas'].prefix.lib)
+ mf.filter('^BLLIB =.*', 'BLLIB = {0}'.format(
+ ' '.join(self.spec['blas'].libs.libraries)))
mf.filter('^CC =.*', 'CC = cc')
- mf.filter('^FC =.*', 'FC = f90')
+ mf.filter('^FC =.*', 'FC = fc')
def install(self, spec, prefix):
make('all')
@@ -53,6 +34,6 @@ class Cblas(Package):
mkdirp(prefix.include)
# Rename the generated lib file to libcblas.a
- install('./lib/cblas_LINUX.a', '%s/libcblas.a' % prefix.lib)
- install('./include/cblas.h', '%s' % prefix.include)
- install('./include/cblas_f77.h', '%s' % prefix.include)
+ install('lib/cblas_LINUX.a', prefix.lib.join('libcblas.a'))
+ install('include/cblas.h', prefix.include)
+ install('include/cblas_f77.h', prefix.include)