summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/cdd/Makefile.spack.patch
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/cdd/Makefile.spack.patch')
-rw-r--r--var/spack/repos/builtin/packages/cdd/Makefile.spack.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/cdd/Makefile.spack.patch b/var/spack/repos/builtin/packages/cdd/Makefile.spack.patch
new file mode 100644
index 0000000000..4c97187a57
--- /dev/null
+++ b/var/spack/repos/builtin/packages/cdd/Makefile.spack.patch
@@ -0,0 +1,22 @@
+--- old/Makefile.spack
++++ new/Makefile.spack
+@@ -0,0 +1,19 @@
++# Set PREFIX to the install location for both building and installing
++
++all: cdd dplex_test
++
++cdd: cdd.lo cddio.lo cddarith.lo dplex.lo setoper.lo
++ libtool --mode=link --tag=CC cc -g -O2 -o $@ $^
++
++dplex_test: dplex.lo dplex_test.lo setoper.lo
++ libtool --mode=link --tag=CC cc -g -O2 -o $@ $^
++
++%.lo: %.c
++ libtool --mode=compile --tag=CC cc -g -O2 -c $*.c
++
++install:
++ mkdir -p $(PREFIX)/bin
++ libtool --mode=install cp cdd $(PREFIX)/bin/cdd
++ libtool --mode=install cp dplex_test $(PREFIX)/bin/dplex_test
++
++.PHONY: all install