summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/citcoms/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/citcoms/package.py')
-rw-r--r--var/spack/repos/builtin/packages/citcoms/package.py27
1 files changed, 11 insertions, 16 deletions
diff --git a/var/spack/repos/builtin/packages/citcoms/package.py b/var/spack/repos/builtin/packages/citcoms/package.py
index 2529e544f6..35fe86b2b4 100644
--- a/var/spack/repos/builtin/packages/citcoms/package.py
+++ b/var/spack/repos/builtin/packages/citcoms/package.py
@@ -12,12 +12,14 @@ class Citcoms(AutotoolsPackage):
homepage = "https://geodynamics.org/cig/software/citcoms/"
url = "https://github.com/geodynamics/citcoms/releases/download/v3.3.1/CitcomS-3.3.1.tar.gz"
+ git = "https://github.com/geodynamics/citcoms.git"
+ maintainers = ['adamjstewart']
+
+ version('master', branch='master', submodules=True)
version('3.3.1', sha256='e3520e0a933e4699d31e86fe309b8c154ea6ecb0f42a1cf6f25e8d13d825a4b3')
version('3.2.0', sha256='773a14d91ecbb4a4d1e04317635fab79819d83c57b47f19380ff30b9b19cb07a')
- variant('pyre', default=False, description='build Pyre modules')
- variant('exchanger', default=False, description='use Exchanger')
variant('ggrd', default=False, description='use GGRD file support')
variant('cuda', default=False, description='use CUDA')
variant('hdf5', default=False, description='add HDF5 support')
@@ -25,17 +27,17 @@ class Citcoms(AutotoolsPackage):
# Required dependencies
depends_on('mpi')
depends_on('zlib')
+ depends_on('python@:2', type='run') # needed for post-processing scripts
+ depends_on('automake', when='@master', type='build')
+ depends_on('autoconf', when='@master', type='build')
+ depends_on('libtool', when='@master', type='build')
+ depends_on('m4', when='@master', type='build')
# Optional dependencies
- depends_on('exchanger', when='+exchanger')
- depends_on('py-pythia', type=('build', 'run'), when='+pyre')
depends_on('hc', when='+ggrd')
depends_on('cuda', when='+cuda')
depends_on('hdf5+mpi', when='+hdf5')
- conflicts('+pyre', when='@3.3:', msg='Pyre support was removed from 3.3+')
- conflicts('+exchanger', when='@3.3:', msg='Exchanger support was removed from 3.3+')
-
def setup_build_environment(self, env):
if '+ggrd' in self.spec:
env.set('HC_HOME', self.spec['hc'].prefix)
@@ -45,15 +47,8 @@ class Citcoms(AutotoolsPackage):
# Flags only valid in 3.2
if self.spec.satisfies('@:3.2'):
- if '+pyre' in self.spec:
- args.append('--with-pyre')
- else:
- args.append('--without-pyre')
-
- if '+exchanger' in self.spec:
- args.append('--with-exchanger')
- else:
- args.append('--without-exchanger')
+ args.append('--without-pyre')
+ args.append('--without-exchanger')
if '+ggrd' in self.spec:
args.append('--with-ggrd')