summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/claw/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/claw/package.py')
-rw-r--r--var/spack/repos/builtin/packages/claw/package.py36
1 files changed, 36 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/claw/package.py b/var/spack/repos/builtin/packages/claw/package.py
new file mode 100644
index 0000000000..d905faf2bc
--- /dev/null
+++ b/var/spack/repos/builtin/packages/claw/package.py
@@ -0,0 +1,36 @@
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
+#
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
+from spack import *
+
+
+class Claw(CMakePackage):
+ """CLAW Compiler targets performance portability problem in climate and
+ weather application written in Fortran. From a single source code, it
+ generates architecture specific code decorated with OpenMP or OpenACC"""
+
+ homepage = 'https://claw-project.github.io/'
+ git = 'https://github.com/claw-project/claw-compiler.git'
+ maintainers = ['clementval']
+
+ version('1.1.0', commit='16b165a443b11b025a77cad830b1280b8c9bcf01', submodules=True)
+
+ depends_on('cmake@3.0:', type='build')
+ depends_on('java@7:')
+ depends_on('ant@1.9:')
+ depends_on('libxml2')
+ depends_on('bison')
+
+ def cmake_args(self):
+ args = []
+ spec = self.spec
+
+ args.append('-DOMNI_CONF_OPTION=--with-libxml2={0}'.
+ format(spec['libxml2'].prefix))
+
+ args.append('-DCMAKE_Fortran_COMPILER={0}'.
+ format(self.compiler.fc))
+
+ return args