summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/cleverleaf/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/cleverleaf/package.py')
-rw-r--r--var/spack/repos/builtin/packages/cleverleaf/package.py39
1 files changed, 12 insertions, 27 deletions
diff --git a/var/spack/repos/builtin/packages/cleverleaf/package.py b/var/spack/repos/builtin/packages/cleverleaf/package.py
index 0e40d3ff4c..65e6ec5f43 100644
--- a/var/spack/repos/builtin/packages/cleverleaf/package.py
+++ b/var/spack/repos/builtin/packages/cleverleaf/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -31,16 +12,20 @@ class Cleverleaf(CMakePackage):
Livermore National Laboratory. The primary goal of CleverLeaf is
to evaluate the application of AMR to the Lagrangian-Eulerian
hydrodynamics scheme used by CloverLeaf.
-
"""
homepage = "http://uk-mac.github.io/CleverLeaf/"
- url = "https://github.com/UK-MAC/CleverLeaf/tarball/master"
+ git = "https://github.com/UK-MAC/CleverLeaf_ref.git"
- version('develop', git='https://github.com/UK-MAC/CleverLeaf_ref.git',
- branch='develop')
+ version('develop', branch='develop')
depends_on('samrai@3.8.0:')
depends_on('hdf5+mpi')
depends_on('boost')
depends_on('cmake@3.1:', type='build')
+
+ def flag_handler(self, name, flags):
+ if self.spec.satisfies('%intel') and name in ['cppflags', 'cxxflags']:
+ flags.append(self.compiler.cxx11_flag)
+
+ return (None, None, flags)