summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/cool/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/cool/package.py')
-rw-r--r--var/spack/repos/builtin/packages/cool/package.py76
1 files changed, 43 insertions, 33 deletions
diff --git a/var/spack/repos/builtin/packages/cool/package.py b/var/spack/repos/builtin/packages/cool/package.py
index 6a2dd0696e..a95778bd1f 100644
--- a/var/spack/repos/builtin/packages/cool/package.py
+++ b/var/spack/repos/builtin/packages/cool/package.py
@@ -8,64 +8,74 @@ from spack.package import *
class Cool(CMakePackage):
"""COOL provides specific software components and tools for the handling of the time
- variation and versioning of the experiment conditions data."""
+ variation and versioning of the experiment conditions data."""
homepage = "https://coral-cool.docs.cern.ch/"
- git = "https://gitlab.cern.ch/lcgcool/cool.git"
+ git = "https://gitlab.cern.ch/lcgcool/cool.git"
- tags = ['hep']
- maintainers = ['iarspider']
+ tags = ["hep"]
+ maintainers = ["iarspider"]
- version('3.3.10', tag='COOL_3_3_10')
- version('3.3.7', tag='COOL_3_3_7')
- version('3.3.5', tag='COOL_3_3_5')
- version('3.3.4', tag='COOL_3_3_4')
- version('3.3.3', tag='COOL_3_3_3')
+ version("3.3.10", tag="COOL_3_3_10")
+ version("3.3.7", tag="COOL_3_3_7")
+ version("3.3.5", tag="COOL_3_3_5")
+ version("3.3.4", tag="COOL_3_3_4")
+ version("3.3.3", tag="COOL_3_3_3")
# Spack-specific patches:
# * Create python/PyCool/_internal directory
# (only necessary for Spack builds, for some reason)
# * Explicitly request Boost components
- patch('cool.patch', level=0, when='@:3.3.8')
+ patch("cool.patch", level=0, when="@:3.3.8")
- @when('@3.3.9:')
+ @when("@3.3.9:")
def patch(self):
- filter_file("find_package(Boost REQUIRED)",
- "find_package(Boost REQUIRED chrono system thread)",
- "src/RelationalCool/CMakeLists.txt")
+ filter_file(
+ "find_package(Boost REQUIRED)",
+ "find_package(Boost REQUIRED chrono system thread)",
+ "src/RelationalCool/CMakeLists.txt",
+ )
# BINARY_TAG is a combination of target, os, compiler name and build type (opt/dbg)
# If you override it, please also override it for CORAL
- variant('binary_tag', default='auto',
- description='Force specific BINARY_TAG, "auto" ' +
- 'will determine the correct value at buildtime')
+ variant(
+ "binary_tag",
+ default="auto",
+ description='Force specific BINARY_TAG, "auto" '
+ + "will determine the correct value at buildtime",
+ )
- depends_on('coral')
- depends_on('root')
- depends_on('vdt')
- depends_on('xz')
- depends_on('qt@5:', when='platform=linux')
- depends_on('boost+chrono+system+thread')
- depends_on('python')
+ depends_on("coral")
+ depends_on("root")
+ depends_on("vdt")
+ depends_on("xz")
+ depends_on("qt@5:", when="platform=linux")
+ depends_on("boost+chrono+system+thread")
+ depends_on("python")
def determine_binary_tag(self):
# As far as I can tell from reading the source code, `binary_tag`
# can be almost arbitrary. The only real difference it makes is
# disabling oracle dependency for non-x86 platforms.
- if self.spec.variants['binary_tag'].value != 'auto':
- return self.spec.variants['binary_tag'].value
+ if self.spec.variants["binary_tag"].value != "auto":
+ return self.spec.variants["binary_tag"].value
- binary_tag = str(self.spec.target.family) + \
- '-' + self.spec.os + \
- '-' + self.spec.compiler.name + str(self.spec.compiler.version.joined) + \
- ('-opt' if 'Rel' in self.spec.variants['build_type'].value else '-dbg')
+ binary_tag = (
+ str(self.spec.target.family)
+ + "-"
+ + self.spec.os
+ + "-"
+ + self.spec.compiler.name
+ + str(self.spec.compiler.version.joined)
+ + ("-opt" if "Rel" in self.spec.variants["build_type"].value else "-dbg")
+ )
return binary_tag
def cmake_args(self):
binary_tag = self.determine_binary_tag()
- args = ['-DBINARY_TAG=' + binary_tag]
- if self.spec['python'].version >= Version("3.0.0"):
- args.append('-DLCG_python3=on')
+ args = ["-DBINARY_TAG=" + binary_tag]
+ if self.spec["python"].version >= Version("3.0.0"):
+ args.append("-DLCG_python3=on")
return args