summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/doxygen/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/doxygen/package.py')
-rw-r--r--var/spack/repos/builtin/packages/doxygen/package.py10
1 files changed, 9 insertions, 1 deletions
diff --git a/var/spack/repos/builtin/packages/doxygen/package.py b/var/spack/repos/builtin/packages/doxygen/package.py
index aa99ca73ee..c43863543d 100644
--- a/var/spack/repos/builtin/packages/doxygen/package.py
+++ b/var/spack/repos/builtin/packages/doxygen/package.py
@@ -17,6 +17,8 @@ class Doxygen(CMakePackage):
git = "https://github.com/doxygen/doxygen.git"
# Doxygen versions on GitHub
+ version('1.8.17', commit='b5fa3cd1c6e6240e20d3b80a70e3f04040b32021')
+ version('1.8.16', commit='cfd73d5c4d1a66c620a3b7c08b72a3f3c3f94255')
version('1.8.15', commit='dc89ac01407c24142698c1374610f2cee1fbf200')
version('1.8.14', commit='2f4139de014bf03898320a45fe52c92872c1e0f4')
version('1.8.12', commit='4951df8d0d0acf843b4147136f945504b96536e7')
@@ -27,9 +29,12 @@ class Doxygen(CMakePackage):
variant('graphviz', default=False,
description='Build with dot command support from Graphviz.')
+ variant('mscgen', default=False,
+ description='Build with support for code graphs from mscgen.')
+
depends_on("cmake@2.8.12:", type='build')
depends_on("python", type='build') # 2 or 3 OK; used in CMake build
- depends_on("libiconv")
+ depends_on("iconv")
depends_on("flex", type='build')
# code.l just checks subminor version <=2.5.4 or >=2.5.33
# but does not recognize 2.6.x as newer...could be patched if needed
@@ -38,6 +43,7 @@ class Doxygen(CMakePackage):
# optional dependencies
depends_on("graphviz", when="+graphviz", type='run')
+ depends_on("mscgen", when="+mscgen", type='run')
# Support C++14's std::shared_ptr. For details about this patch, see
# https://github.com/Sleepyowl/doxygen/commit/6c380ba91ae41c6d5c409a5163119318932ae2a3?diff=unified
@@ -45,6 +51,8 @@ class Doxygen(CMakePackage):
patch('shared_ptr.patch', when='@1.8.14')
def patch(self):
+ if self.spec['iconv'].name == 'libc':
+ return
# On Linux systems, iconv is provided by libc. Since CMake finds the
# symbol in libc, it does not look for libiconv, which leads to linker
# errors. This makes sure that CMake always looks for the external