summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/emacs/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/emacs/package.py')
-rw-r--r--var/spack/repos/builtin/packages/emacs/package.py49
1 files changed, 23 insertions, 26 deletions
diff --git a/var/spack/repos/builtin/packages/emacs/package.py b/var/spack/repos/builtin/packages/emacs/package.py
index 4b0d7a9689..1599782d50 100644
--- a/var/spack/repos/builtin/packages/emacs/package.py
+++ b/var/spack/repos/builtin/packages/emacs/package.py
@@ -1,36 +1,20 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
+import sys
+
class Emacs(AutotoolsPackage):
"""The Emacs programmable text editor."""
homepage = "https://www.gnu.org/software/emacs"
- url = "http://ftp.gnu.org/gnu/emacs/emacs-24.5.tar.gz"
+ url = "https://ftpmirror.gnu.org/emacs/emacs-24.5.tar.gz"
+ version('26.1', '544d2ab5eb142e9ca69adb023d17bf4b')
version('25.3', '74ddd373dc52ac05ca7a8c63b1ddbf58')
version('25.2', '0a36d1cdbba6024d4dbbac027f87995f')
version('25.1', '95c12e6a9afdf0dcbdd7d2efa26ca42c')
@@ -43,10 +27,12 @@ class Emacs(AutotoolsPackage):
values=('gtk', 'athena'),
description="Select an X toolkit (gtk, athena)"
)
+ variant('tls', default=False, description="Build Emacs with gnutls")
- depends_on('pkg-config@0.9.0:', type='build')
+ depends_on('pkgconfig', type='build')
depends_on('ncurses')
+ depends_on('pcre')
depends_on('zlib')
depends_on('libtiff', when='+X')
depends_on('libpng', when='+X')
@@ -54,7 +40,8 @@ class Emacs(AutotoolsPackage):
depends_on('giflib', when='+X')
depends_on('libx11', when='+X')
depends_on('libxaw', when='+X toolkit=athena')
- depends_on('gtkplus+X', when='+X toolkit=gtk')
+ depends_on('gtkplus', when='+X toolkit=gtk')
+ depends_on('gnutls', when='+tls')
def configure_args(self):
spec = self.spec
@@ -68,4 +55,14 @@ class Emacs(AutotoolsPackage):
else:
args = ['--without-x']
+ # On OS X/macOS, do not build "nextstep/Emacs.app", because
+ # doing so throws an error at build-time
+ if sys.platform == 'darwin':
+ args.append('--without-ns')
+
+ if '+tls' in spec:
+ args.append('--with-gnutls')
+ else:
+ args.append('--without-gnutls')
+
return args