summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/farmhash/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/farmhash/package.py')
-rw-r--r--var/spack/repos/builtin/packages/farmhash/package.py42
1 files changed, 0 insertions, 42 deletions
diff --git a/var/spack/repos/builtin/packages/farmhash/package.py b/var/spack/repos/builtin/packages/farmhash/package.py
deleted file mode 100644
index 071a43c1a2..0000000000
--- a/var/spack/repos/builtin/packages/farmhash/package.py
+++ /dev/null
@@ -1,42 +0,0 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
-#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
-from spack import *
-import os.path
-from shutil import copyfile
-
-
-class Farmhash(CMakePackage):
- """
- FarmHash provides hash functions for strings and other data.
- """
-
- homepage = "https://github.com/google/farmhash"
-
- version('92e897', git='https://github.com/google/farmhash.git',
- commit='92e897b282426729f4724d91a637596c7e2fe28f')
-
- def patch(self):
- copyfile(join_path(os.path.dirname(__file__), "CMakeLists.txt"),
- "CMakeLists.txt")