summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/flann/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/flann/package.py')
-rw-r--r--var/spack/repos/builtin/packages/flann/package.py37
1 files changed, 10 insertions, 27 deletions
diff --git a/var/spack/repos/builtin/packages/flann/package.py b/var/spack/repos/builtin/packages/flann/package.py
index 1ed996bd51..7aee67b66c 100644
--- a/var/spack/repos/builtin/packages/flann/package.py
+++ b/var/spack/repos/builtin/packages/flann/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -92,6 +73,12 @@ class Flann(CMakePackage):
# Example uses hdf5.
depends_on("hdf5", when="+examples")
+ depends_on('hdf5', type='test')
+ depends_on('gtest', type='test')
+
+ # See: https://github.com/mariusmuja/flann/issues/369
+ patch('linux-gcc-cmakev3.11-plus.patch', when='%gcc^cmake@3.11:')
+
def patch(self):
# Fix up the python setup.py call inside the install(CODE
filter_file("setup.py install",
@@ -109,10 +96,6 @@ class Flann(CMakePackage):
"# install( FILES",
"src/python/CMakeLists.txt", string=True)
- # TODO: revisit after https://github.com/spack/spack/issues/1279
- # depends_on('hdf5', type='test')
- # depends_on('gtest', type='test')
-
def cmake_args(self):
spec = self.spec
args = []