summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/flecsi/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/flecsi/package.py')
-rw-r--r--var/spack/repos/builtin/packages/flecsi/package.py8
1 files changed, 1 insertions, 7 deletions
diff --git a/var/spack/repos/builtin/packages/flecsi/package.py b/var/spack/repos/builtin/packages/flecsi/package.py
index 947719508c..24c3e6b4d7 100644
--- a/var/spack/repos/builtin/packages/flecsi/package.py
+++ b/var/spack/repos/builtin/packages/flecsi/package.py
@@ -39,7 +39,7 @@ class Flecsi(CMakePackage):
homepage = "http://flecsi.lanl.gov/"
url = "https://github.com/laristra/flecsi/tarball/v1.0"
- version('develop', git='https://github.com/laristra/flecsi', branch='master', submodules=False)
+ version('develop', git='https://github.com/laristra/flecsi', branch='master', submodules=True)
variant('debug', default=False, description='Build debug version')
variant('mpi', default=True,
@@ -49,12 +49,6 @@ class Flecsi(CMakePackage):
depends_on("legion+shared", when='~mpi')
depends_on("legion+shared+mpi", when='+mpi')
- # drop when #3958 has been merged
- def do_fetch(self, mirror_only=True):
- super(Flecsi, self).do_fetch(mirror_only)
- git = which("git")
- git('-C', 'flecsi', 'submodule', 'update', '--init', '--recursive')
-
def build_type(self):
spec = self.spec
if '+debug' in spec: