summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/fmt/fmt-no-export-cpp11flag_3.0.0.patch
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/fmt/fmt-no-export-cpp11flag_3.0.0.patch')
-rw-r--r--var/spack/repos/builtin/packages/fmt/fmt-no-export-cpp11flag_3.0.0.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/fmt/fmt-no-export-cpp11flag_3.0.0.patch b/var/spack/repos/builtin/packages/fmt/fmt-no-export-cpp11flag_3.0.0.patch
new file mode 100644
index 0000000000..6b5ea4d867
--- /dev/null
+++ b/var/spack/repos/builtin/packages/fmt/fmt-no-export-cpp11flag_3.0.0.patch
@@ -0,0 +1,13 @@
+diff --git a/fmt/CMakeLists.txt b/fmt/CMakeLists.txt
+index c0ef02e..1634924 100644
+--- a/fmt/CMakeLists.txt
++++ b/fmt/CMakeLists.txt
+@@ -14,8 +14,6 @@ if (FMT_CPPFORMAT)
+ add_library(cppformat ${FMT_SOURCES} ${FMT_HEADERS})
+ endif ()
+
+-# Starting with cmake 3.1 the CXX_STANDARD property can be used instead.
+-target_compile_options(fmt PUBLIC ${CPP11_FLAG})
+ if (FMT_PEDANTIC)
+ target_compile_options(fmt PRIVATE ${PEDANTIC_COMPILE_FLAGS})
+ endif ()