summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/gcc/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/gcc/package.py')
-rw-r--r--var/spack/repos/builtin/packages/gcc/package.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/var/spack/repos/builtin/packages/gcc/package.py b/var/spack/repos/builtin/packages/gcc/package.py
index f36980d8e7..6fbfdd27b1 100644
--- a/var/spack/repos/builtin/packages/gcc/package.py
+++ b/var/spack/repos/builtin/packages/gcc/package.py
@@ -681,7 +681,9 @@ class Gcc(AutotoolsPackage, GNUMirrorPackage):
# concretization, so we'll stick to that. The other way around however can
# result in compilation errors, when gcc@7 is built with gcc@11, and znver3
# is taken as a the target, which gcc@7 doesn't support.
- if "+bootstrap %gcc" in self.spec:
+ # Note we're not adding this for aarch64 because of
+ # https://github.com/spack/spack/issues/31184
+ if "+bootstrap %gcc" in self.spec and self.spec.target.family != "aarch64":
flags += " " + self.get_common_target_flags(self.spec)
if "+bootstrap" in self.spec: