summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/gcc/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/gcc/package.py')
-rw-r--r--var/spack/repos/builtin/packages/gcc/package.py61
1 files changed, 41 insertions, 20 deletions
diff --git a/var/spack/repos/builtin/packages/gcc/package.py b/var/spack/repos/builtin/packages/gcc/package.py
index f8958ee290..6043b62279 100644
--- a/var/spack/repos/builtin/packages/gcc/package.py
+++ b/var/spack/repos/builtin/packages/gcc/package.py
@@ -26,6 +26,8 @@ from spack import *
from contextlib import closing
from glob import glob
+import sys
+import os
class Gcc(Package):
"""The GNU Compiler Collection includes front ends for C, C++,
@@ -47,24 +49,33 @@ class Gcc(Package):
version('4.6.4', 'b407a3d1480c11667f293bfb1f17d1a4')
version('4.5.4', '27e459c2566b8209ab064570e1b378f7')
- variant('gold', default=True, description="Build the gold linker plugin for ld-based LTO")
+ variant('binutils', default=sys.platform != 'darwin',
+ description="Build via binutils")
+ variant('gold', default=sys.platform != 'darwin',
+ description="Build the gold linker plugin for ld-based LTO")
depends_on("mpfr")
depends_on("gmp")
depends_on("mpc", when='@4.5:')
depends_on("isl", when='@5.0:')
- depends_on("binutils~libiberty", when='~gold')
- depends_on("binutils~libiberty+gold", when='+gold')
+ depends_on("binutils~libiberty", when='+binutils ~gold')
+ depends_on("binutils~libiberty+gold", when='+binutils +gold')
+ # TODO: integrate these libraries.
#depends_on("ppl")
#depends_on("cloog")
+ if sys.platform == 'darwin':
+ patch('darwin/gcc-4.9.patch1', when='@4.9.3')
+ patch('darwin/gcc-4.9.patch2', when='@4.9.3')
def install(self, spec, prefix):
# libjava/configure needs a minor fix to install into spack paths.
- filter_file(r"'@.*@'", "'@[[:alnum:]]*@'", 'libjava/configure', string=True)
+ filter_file(r"'@.*@'", "'@[[:alnum:]]*@'", 'libjava/configure',
+ string=True)
enabled_languages = set(('c', 'c++', 'fortran', 'java', 'objc'))
- if spec.satisfies("@4.7.1:"):
+
+ if spec.satisfies("@4.7.1:") and sys.platform != 'darwin':
enabled_languages.add('go')
# Generic options to compile GCC
@@ -72,32 +83,40 @@ class Gcc(Package):
"--libdir=%s/lib64" % prefix,
"--disable-multilib",
"--enable-languages=" + ','.join(enabled_languages),
- "--with-mpc=%s" % spec['mpc'].prefix,
- "--with-mpfr=%s" % spec['mpfr'].prefix,
- "--with-gmp=%s" % spec['gmp'].prefix,
+ "--with-mpc=%s" % spec['mpc'].prefix,
+ "--with-mpfr=%s" % spec['mpfr'].prefix,
+ "--with-gmp=%s" % spec['gmp'].prefix,
"--enable-lto",
- "--with-gnu-ld",
- "--with-gnu-as",
"--with-quad"]
# Binutils
- static_bootstrap_flags = "-static-libstdc++ -static-libgcc"
- binutils_options = ["--with-sysroot=/",
- "--with-stage1-ldflags=%s %s" % (self.rpath_args, static_bootstrap_flags),
- "--with-boot-ldflags=%s %s" % (self.rpath_args, static_bootstrap_flags),
- "--with-ld=%s/bin/ld" % spec['binutils'].prefix,
- "--with-as=%s/bin/as" % spec['binutils'].prefix]
- options.extend(binutils_options)
+ if spec.satisfies('+binutils'):
+ static_bootstrap_flags = "-static-libstdc++ -static-libgcc"
+ binutils_options = ["--with-sysroot=/",
+ "--with-stage1-ldflags=%s %s" %
+ (self.rpath_args, static_bootstrap_flags),
+ "--with-boot-ldflags=%s %s" %
+ (self.rpath_args, static_bootstrap_flags),
+ "--with-gnu-ld",
+ "--with-ld=%s/bin/ld" % spec['binutils'].prefix,
+ "--with-gnu-as",
+ "--with-as=%s/bin/as" % spec['binutils'].prefix]
+ options.extend(binutils_options)
# Isl
if 'isl' in spec:
isl_options = ["--with-isl=%s" % spec['isl'].prefix]
options.extend(isl_options)
+ if sys.platform == 'darwin' :
+ darwin_options = [ "--with-build-config=bootstrap-debug" ]
+ options.extend(darwin_options)
+
build_dir = join_path(self.stage.path, 'spack-build')
configure = Executable( join_path(self.stage.source_path, 'configure') )
with working_dir(build_dir, create=True):
# Rest of install is straightforward.
configure(*options)
- make()
+ if sys.platform == 'darwin' : make("bootstrap")
+ else: make()
make("install")
self.write_rpath_specs()
@@ -114,7 +133,8 @@ class Gcc(Package):
"""Generate a spec file so the linker adds a rpath to the libs
the compiler used to build the executable."""
if not self.spec_dir:
- tty.warn("Could not install specs for %s." % self.spec.format('$_$@'))
+ tty.warn("Could not install specs for %s." %
+ self.spec.format('$_$@'))
return
gcc = Executable(join_path(self.prefix.bin, 'gcc'))
@@ -124,5 +144,6 @@ class Gcc(Package):
for line in lines:
out.write(line + "\n")
if line.startswith("*link:"):
- out.write("-rpath %s/lib:%s/lib64 \\\n"% (self.prefix, self.prefix))
+ out.write("-rpath %s/lib:%s/lib64 \\\n" %
+ (self.prefix, self.prefix))
set_install_permissions(specs_file)