summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/gdl/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/gdl/package.py')
-rw-r--r--var/spack/repos/builtin/packages/gdl/package.py10
1 files changed, 0 insertions, 10 deletions
diff --git a/var/spack/repos/builtin/packages/gdl/package.py b/var/spack/repos/builtin/packages/gdl/package.py
index 4cfe69dca7..10a05f7a92 100644
--- a/var/spack/repos/builtin/packages/gdl/package.py
+++ b/var/spack/repos/builtin/packages/gdl/package.py
@@ -26,7 +26,6 @@ class Gdl(CMakePackage):
variant("hdf5", default=True, description="Enable HDF5")
variant("openmp", default=True, description="Enable OpenMP")
variant("proj", default=True, description="Enable LIBPROJ4")
- variant("embed_python", default=False, description="Ability to embed Python within GDL")
variant("python", default=False, description="Build the GDL Python module")
variant("wx", default=False, description="Enable WxWidgets")
variant("x11", default=False, description="Enable X11")
@@ -44,8 +43,6 @@ class Gdl(CMakePackage):
# Too many dependencies to test if GDL supports PROJ.6,
# so restricting to old API
depends_on("proj@:5", when="+proj")
- depends_on("py-numpy", type=("build", "run"), when="+embed_python")
- depends_on("python@2.7:2.8", type=("build", "run"), when="+embed_python")
depends_on("wxwidgets", when="+wx")
depends_on("eigen")
@@ -62,8 +59,6 @@ class Gdl(CMakePackage):
depends_on("libtirpc", type="link")
depends_on("libgeotiff", type="link")
- conflicts("+python", when="~embed_python")
-
# Building the Python module requires patches currently targetting 0.9.8
# othwerwise asking for the Python module *only* builds the Python module
conflicts("+python", when="@:0.9.7,0.9.9:")
@@ -113,11 +108,6 @@ class Gdl(CMakePackage):
else:
args += ["-DLIBPROJ4=OFF"]
- if "+embed_python" in self.spec:
- args += ["-DPYTHON=ON"]
- else:
- args += ["-DPYTHON=OFF"]
-
if "+python" in self.spec:
args += ["-DPYTHON_MODULE=ON"]
else: