summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/ghost/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/ghost/package.py')
-rw-r--r--var/spack/repos/builtin/packages/ghost/package.py57
1 files changed, 26 insertions, 31 deletions
diff --git a/var/spack/repos/builtin/packages/ghost/package.py b/var/spack/repos/builtin/packages/ghost/package.py
index f0d491d971..64b633eefa 100644
--- a/var/spack/repos/builtin/packages/ghost/package.py
+++ b/var/spack/repos/builtin/packages/ghost/package.py
@@ -9,52 +9,47 @@ from spack.package import *
class Ghost(CMakePackage, CudaPackage):
"""GHOST: a General, Hybrid and Optimized Sparse Toolkit.
- This library provides highly optimized building blocks for implementing
- sparse iterative eigenvalue and linear solvers multi- and manycore
- clusters and on heterogenous CPU/GPU machines. For an iterative solver
- library using these kernels, see the phist package.
+ This library provides highly optimized building blocks for implementing
+ sparse iterative eigenvalue and linear solvers multi- and manycore
+ clusters and on heterogenous CPU/GPU machines. For an iterative solver
+ library using these kernels, see the phist package.
"""
homepage = "https://www.bitbucket.org/essex/ghost/"
- git = "https://bitbucket.org/essex/ghost/ghost.git"
+ git = "https://bitbucket.org/essex/ghost/ghost.git"
- version('develop', branch='devel')
+ version("develop", branch="devel")
- variant('shared', default=True,
- description='Enables the build of shared libraries')
- variant('mpi', default=True,
- description='enable/disable MPI')
- variant('scotch', default=False,
- description='enable/disable matrix reordering with PT-SCOTCH')
- variant('zoltan', default=False,
- description='enable/disable matrix reordering with Zoltan')
+ variant("shared", default=True, description="Enables the build of shared libraries")
+ variant("mpi", default=True, description="enable/disable MPI")
+ variant("scotch", default=False, description="enable/disable matrix reordering with PT-SCOTCH")
+ variant("zoltan", default=False, description="enable/disable matrix reordering with Zoltan")
# ###################### Dependencies ##########################
# Everything should be compiled position independent (-fpic)
- depends_on('cmake@3.5:', type='build')
- depends_on('hwloc')
- depends_on('blas')
- depends_on('mpi', when='+mpi')
- depends_on('scotch', when='+scotch')
- depends_on('zoltan', when='+zoltan')
+ depends_on("cmake@3.5:", type="build")
+ depends_on("hwloc")
+ depends_on("blas")
+ depends_on("mpi", when="+mpi")
+ depends_on("scotch", when="+scotch")
+ depends_on("zoltan", when="+zoltan")
def cmake_args(self):
spec = self.spec
# note: we require the cblas_include_dir property from the blas
# provider, this is implemented at least for intel-mkl and
# netlib-lapack
- args = [self.define_from_variant('GHOST_ENABLE_MPI', 'mpi'),
- self.define_from_variant('GHOST_USE_CUDA', 'cuda'),
- self.define_from_variant('GHOST_USE_SCOTCH', 'scotch'),
- self.define_from_variant('GHOST_USE_ZOLTAN', 'zoltan'),
- self.define_from_variant('BUILD_SHARED_LIBS', 'shared'),
- '-DCBLAS_INCLUDE_DIR:STRING=%s'
- % format(spec['blas'].headers.directories[0]),
- '-DBLAS_LIBRARIES=%s'
- % spec['blas:c'].libs.joined(';')
- ]
+ args = [
+ self.define_from_variant("GHOST_ENABLE_MPI", "mpi"),
+ self.define_from_variant("GHOST_USE_CUDA", "cuda"),
+ self.define_from_variant("GHOST_USE_SCOTCH", "scotch"),
+ self.define_from_variant("GHOST_USE_ZOLTAN", "zoltan"),
+ self.define_from_variant("BUILD_SHARED_LIBS", "shared"),
+ "-DCBLAS_INCLUDE_DIR:STRING=%s" % format(spec["blas"].headers.directories[0]),
+ "-DBLAS_LIBRARIES=%s" % spec["blas:c"].libs.joined(";"),
+ ]
return args
def check(self):
- make('test')
+ make("test")