summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/go-bootstrap/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/go-bootstrap/package.py')
-rw-r--r--var/spack/repos/builtin/packages/go-bootstrap/package.py46
1 files changed, 9 insertions, 37 deletions
diff --git a/var/spack/repos/builtin/packages/go-bootstrap/package.py b/var/spack/repos/builtin/packages/go-bootstrap/package.py
index 0228aa74d9..b1f94fc594 100644
--- a/var/spack/repos/builtin/packages/go-bootstrap/package.py
+++ b/var/spack/repos/builtin/packages/go-bootstrap/package.py
@@ -1,30 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
-import os
-import shutil
-import glob
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
# THIS PACKAGE SHOULD NOT EXIST
@@ -36,8 +14,8 @@ from spack import *
class GoBootstrap(Package):
"""Old C-bootstrapped go to bootstrap real go"""
+
homepage = "https://golang.org"
- url = "https://go.googlesource.com/go"
extendable = True
@@ -46,12 +24,14 @@ class GoBootstrap(Package):
# See: https://golang.org/doc/install/source#go14 and
# https://github.com/golang/go/issues/17545 and
# https://github.com/golang/go/issues/16352
+ version('1.4-bootstrap-20171003', 'dbf727a4b0e365bf88d97cbfde590016',
+ url='https://dl.google.com/go/go1.4-bootstrap-20171003.tar.gz')
version('1.4-bootstrap-20170531', 'd2cc61cb9f829b3510ee39c0c5568014',
url='https://storage.googleapis.com/golang/go1.4-bootstrap-20170531.tar.gz')
version('1.4-bootstrap-20161024', '76e42c8152e8560ded880a6d1d1f53cb',
url='https://storage.googleapis.com/golang/go1.4-bootstrap-20161024.tar.gz')
- provides('golang@:1.4-bootstrap-20170531')
+ provides('golang@:1.4-bootstrap-20171003')
depends_on('git', type=('build', 'link', 'run'))
@@ -73,15 +53,7 @@ class GoBootstrap(Package):
with working_dir('src'):
bash('{0}.bash'.format('all' if self.run_tests else 'make'))
- try:
- os.makedirs(prefix)
- except OSError:
- pass
- for f in glob.glob('*'):
- if os.path.isdir(f):
- shutil.copytree(f, os.path.join(prefix, f))
- else:
- shutil.copy2(f, os.path.join(prefix, f))
+ install_tree('.', prefix)
def setup_dependent_environment(self, spack_env, run_env, dependent_spec):
spack_env.set('GOROOT_BOOTSTRAP', self.spec.prefix)