summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/googletest/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/googletest/package.py')
-rw-r--r--var/spack/repos/builtin/packages/googletest/package.py45
1 files changed, 20 insertions, 25 deletions
diff --git a/var/spack/repos/builtin/packages/googletest/package.py b/var/spack/repos/builtin/packages/googletest/package.py
index 5eab658bac..95bdff7473 100644
--- a/var/spack/repos/builtin/packages/googletest/package.py
+++ b/var/spack/repos/builtin/packages/googletest/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -37,6 +18,11 @@ class Googletest(CMakePackage):
variant('gmock', default=False, description='Build with gmock')
conflicts('+gmock', when='@:1.7.0')
+ variant('pthreads', default=True,
+ description='Build multithreaded version with pthreads')
+ variant('shared', default=True,
+ description='Build shared libraries (DLLs)')
+
def cmake_args(self):
spec = self.spec
if '@1.8.0:' in spec:
@@ -49,6 +35,11 @@ class Googletest(CMakePackage):
else:
# Old style (contains only GTest)
options = []
+
+ options.append('-Dgtest_disable_pthreads={0}'.format(
+ 'ON' if '+pthreads' in spec else 'OFF'))
+ options.append('-DBUILD_SHARED_LIBS={0}'.format(
+ 'ON' if '+shared' in spec else 'OFF'))
return options
@when('@:1.7.0')
@@ -61,5 +52,9 @@ class Googletest(CMakePackage):
prefix.include)
mkdirp(prefix.lib)
- install('libgtest.a', prefix.lib)
- install('libgtest_main.a', prefix.lib)
+ if '+shared' in spec:
+ install('libgtest.{0}'.format(dso_suffix), prefix.lib)
+ install('libgtest_main.{0}'.format(dso_suffix), prefix.lib)
+ else:
+ install('libgtest.a', prefix.lib)
+ install('libgtest_main.a', prefix.lib)