summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/gotcha/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/gotcha/package.py')
-rw-r--r--var/spack/repos/builtin/packages/gotcha/package.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/var/spack/repos/builtin/packages/gotcha/package.py b/var/spack/repos/builtin/packages/gotcha/package.py
new file mode 100644
index 0000000000..e1677a4711
--- /dev/null
+++ b/var/spack/repos/builtin/packages/gotcha/package.py
@@ -0,0 +1,27 @@
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
+#
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
+from spack import *
+
+
+class Gotcha(CMakePackage):
+ """C software library for shared library function wrapping,
+ enables tools to intercept calls into shared libraries"""
+
+ homepage = "http://github.com/LLNL/gotcha"
+ git = "https://github.com/LLNL/gotcha.git"
+
+ version('develop', branch='develop')
+ version('master', branch='master')
+ version('1.0.2', tag='1.0.2')
+ version('0.0.2', tag='0.0.2')
+
+ variant('test', default=False, description='Build tests for Gotcha')
+
+ def configure_args(self):
+ spec = self.spec
+ return [
+ '-DGOTCHA_ENABLE_TESTS=%s' % ('ON' if '+test' in spec else 'OFF')
+ ]