summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/graphmap/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/graphmap/package.py')
-rw-r--r--var/spack/repos/builtin/packages/graphmap/package.py16
1 files changed, 8 insertions, 8 deletions
diff --git a/var/spack/repos/builtin/packages/graphmap/package.py b/var/spack/repos/builtin/packages/graphmap/package.py
index 5ac28fd800..bdd30c0a20 100644
--- a/var/spack/repos/builtin/packages/graphmap/package.py
+++ b/var/spack/repos/builtin/packages/graphmap/package.py
@@ -10,19 +10,19 @@ class Graphmap(MakefilePackage):
"""A highly sensitive and accurate mapper for long, error-prone reads"""
homepage = "https://github.com/isovic/graphmap"
- git = "https://github.com/isovic/graphmap.git"
+ git = "https://github.com/isovic/graphmap.git"
- version('0.3.0', commit='eb8c75d68b03be95464318afa69b645a59f8f6b7')
+ version("0.3.0", commit="eb8c75d68b03be95464318afa69b645a59f8f6b7")
- depends_on('zlib', type='link')
+ depends_on("zlib", type="link")
def edit(self, spec, prefix):
mkdirp(prefix.bin)
- makefile = FileFilter('Makefile')
- makefile.filter('/usr/bin/graphmap', prefix.bin.graphmap)
- if self.spec.target.family == 'aarch64':
- makefile.filter('-m64', '')
+ makefile = FileFilter("Makefile")
+ makefile.filter("/usr/bin/graphmap", prefix.bin.graphmap)
+ if self.spec.target.family == "aarch64":
+ makefile.filter("-m64", "")
def build(self, spec, prefix):
- make('modules')
+ make("modules")
make()