summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/gtkorvo-atl/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/gtkorvo-atl/package.py')
-rw-r--r--var/spack/repos/builtin/packages/gtkorvo-atl/package.py46
1 files changed, 19 insertions, 27 deletions
diff --git a/var/spack/repos/builtin/packages/gtkorvo-atl/package.py b/var/spack/repos/builtin/packages/gtkorvo-atl/package.py
index 72bcf12c1d..1dad459cb3 100644
--- a/var/spack/repos/builtin/packages/gtkorvo-atl/package.py
+++ b/var/spack/repos/builtin/packages/gtkorvo-atl/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the LICENSE file for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -31,14 +12,25 @@ class GtkorvoAtl(CMakePackage):
"""
homepage = "https://github.com/GTkorvo/atl"
- url = "https://github.com/GTkorvo/atl/archive/v2.1.tar.gz"
+ url = "https://github.com/GTkorvo/atl/archive/v2.1.tar.gz"
+ git = "https://github.com/GTkorvo/atl.git"
- version('develop', git='https://github.com/GTkorvo/atl.git',
- branch='master')
+ version('develop', branch='master')
+ version('2.2', 'f0e3581e4b4c6943bf4b203685630564')
version('2.1', 'b2324ff041bccba127330a0e1b241978')
depends_on('gtkorvo-cercs-env')
def cmake_args(self):
- args = ["-DENABLE_TESTING=0", "-DENABLE_BUILD_STATIC=STATIC"]
+ args = []
+ if self.spec.satisfies('@2.2:'):
+ args.append("-DBUILD_SHARED_LIBS=OFF")
+ else:
+ args.append("-DENABLE_BUILD_STATIC=STATIC")
+
+ if self.run_tests:
+ args.append('-DENABLE_TESTING=1')
+ else:
+ args.append('-DENABLE_TESTING=0')
+
return args