summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/hisea/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/hisea/package.py')
-rw-r--r--var/spack/repos/builtin/packages/hisea/package.py17
1 files changed, 10 insertions, 7 deletions
diff --git a/var/spack/repos/builtin/packages/hisea/package.py b/var/spack/repos/builtin/packages/hisea/package.py
index 66b4e8db2f..08a945a30c 100644
--- a/var/spack/repos/builtin/packages/hisea/package.py
+++ b/var/spack/repos/builtin/packages/hisea/package.py
@@ -9,13 +9,16 @@ from spack.pkg.builtin.boost import Boost
class Hisea(MakefilePackage):
"""HISEA is an efficient all-vs-all long read aligner for SMRT sequencing
- data. Its algorithm is designed to produce highest alignment sensitivity
- among others."""
+ data. Its algorithm is designed to produce highest alignment sensitivity
+ among others."""
homepage = "https://doi.org/10.1186/s12859-017-1953-9"
- version('2017.12.26', sha256='3c6ddfb8490a327cc5f9e45f64cd4312abc6ef5719661ce8892db8a20a1e9c5e',
- url='https://github.com/lucian-ilie/HISEA/tarball/39e01e98caa0f2101da806ca59306296effe789c')
+ version(
+ "2017.12.26",
+ sha256="3c6ddfb8490a327cc5f9e45f64cd4312abc6ef5719661ce8892db8a20a1e9c5e",
+ url="https://github.com/lucian-ilie/HISEA/tarball/39e01e98caa0f2101da806ca59306296effe789c",
+ )
# TODO: replace this with an explicit list of components of Boost,
# for instance depends_on('boost +filesystem')
@@ -23,9 +26,9 @@ class Hisea(MakefilePackage):
depends_on(Boost.with_default_variants)
def patch(self):
- if self.spec.target.family == 'aarch64':
- filter_file('-mpopcnt', '', 'Makefile')
+ if self.spec.target.family == "aarch64":
+ filter_file("-mpopcnt", "", "Makefile")
def install(self, spec, prefix):
mkdirp(prefix.bin)
- install('hisea', prefix.bin)
+ install("hisea", prefix.bin)