summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/hisea/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/hisea/package.py')
-rw-r--r--var/spack/repos/builtin/packages/hisea/package.py6
1 files changed, 5 insertions, 1 deletions
diff --git a/var/spack/repos/builtin/packages/hisea/package.py b/var/spack/repos/builtin/packages/hisea/package.py
index af6fc9f621..25f566fa66 100644
--- a/var/spack/repos/builtin/packages/hisea/package.py
+++ b/var/spack/repos/builtin/packages/hisea/package.py
@@ -4,6 +4,7 @@
# SPDX-License-Identifier: (Apache-2.0 OR MIT)
from spack import *
+from spack.pkg.builtin.boost import Boost
class Hisea(MakefilePackage):
@@ -16,7 +17,10 @@ class Hisea(MakefilePackage):
version('2017.12.26', sha256='3c6ddfb8490a327cc5f9e45f64cd4312abc6ef5719661ce8892db8a20a1e9c5e',
url='https://github.com/lucian-ilie/HISEA/tarball/39e01e98caa0f2101da806ca59306296effe789c')
- depends_on('boost')
+ # TODO: replace this with an explicit list of components of Boost,
+ # for instance depends_on('boost +filesystem')
+ # See https://github.com/spack/spack/pull/22303 for reference
+ depends_on(Boost.with_default_variants)
def patch(self):
if self.spec.target.family == 'aarch64':