summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/kcov/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/kcov/package.py')
-rw-r--r--var/spack/repos/builtin/packages/kcov/package.py20
1 files changed, 10 insertions, 10 deletions
diff --git a/var/spack/repos/builtin/packages/kcov/package.py b/var/spack/repos/builtin/packages/kcov/package.py
index 9e21767a9c..9fd1cbc2c4 100644
--- a/var/spack/repos/builtin/packages/kcov/package.py
+++ b/var/spack/repos/builtin/packages/kcov/package.py
@@ -12,24 +12,24 @@ class Kcov(CMakePackage):
compilation options"""
homepage = "https://simonkagstrom.github.io/kcov/index.html"
- url = "https://github.com/SimonKagstrom/kcov/archive/38.tar.gz"
+ url = "https://github.com/SimonKagstrom/kcov/archive/38.tar.gz"
- version('38', sha256='b37af60d81a9b1e3b140f9473bdcb7975af12040feb24cc666f9bb2bb0be68b4')
+ version("38", sha256="b37af60d81a9b1e3b140f9473bdcb7975af12040feb24cc666f9bb2bb0be68b4")
- depends_on('cmake@2.8.4:', type='build')
- depends_on('zlib')
- depends_on('curl')
- depends_on('elfutils', when='platform=linux')
- depends_on('binutils +libiberty', when='platform=linux', type='link')
+ depends_on("cmake@2.8.4:", type="build")
+ depends_on("zlib")
+ depends_on("curl")
+ depends_on("elfutils", when="platform=linux")
+ depends_on("binutils +libiberty", when="platform=linux", type="link")
def cmake_args(self):
# Necessary at least on macOS, fixes linking error to LLDB
# https://github.com/Homebrew/homebrew-core/blob/master/Formula/kcov.rb
- return ['-DSPECIFY_RPATH=ON']
+ return ["-DSPECIFY_RPATH=ON"]
- @run_after('install')
+ @run_after("install")
@on_package_attributes(run_tests=True)
def test_install(self):
# The help message exits with an exit code of 1
kcov = Executable(self.prefix.bin.kcov)
- kcov('-h', ignore_errors=1)
+ kcov("-h", ignore_errors=1)