summaryrefslogtreecommitdiff
path: root/var/spack/repos/builtin/packages/laghos/package.py
diff options
context:
space:
mode:
Diffstat (limited to 'var/spack/repos/builtin/packages/laghos/package.py')
-rw-r--r--var/spack/repos/builtin/packages/laghos/package.py64
1 files changed, 31 insertions, 33 deletions
diff --git a/var/spack/repos/builtin/packages/laghos/package.py b/var/spack/repos/builtin/packages/laghos/package.py
index 0e889782e6..deab6d8f0b 100644
--- a/var/spack/repos/builtin/packages/laghos/package.py
+++ b/var/spack/repos/builtin/packages/laghos/package.py
@@ -1,27 +1,8 @@
-##############################################################################
-# Copyright (c) 2013-2017, Lawrence Livermore National Security, LLC.
-# Produced at the Lawrence Livermore National Laboratory.
+# Copyright 2013-2018 Lawrence Livermore National Security, LLC and other
+# Spack Project Developers. See the top-level COPYRIGHT file for details.
#
-# This file is part of Spack.
-# Created by Todd Gamblin, tgamblin@llnl.gov, All rights reserved.
-# LLNL-CODE-647188
-#
-# For details, see https://github.com/spack/spack
-# Please also see the NOTICE and LICENSE files for our notice and the LGPL.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU Lesser General Public License (as
-# published by the Free Software Foundation) version 2.1, February 1999.
-#
-# This program is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the IMPLIED WARRANTY OF
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the terms and
-# conditions of the GNU Lesser General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public
-# License along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-##############################################################################
+# SPDX-License-Identifier: (Apache-2.0 OR MIT)
+
from spack import *
@@ -33,15 +14,21 @@ class Laghos(MakefilePackage):
"""
tags = ['proxy-app', 'ecp-proxy-app']
- homepage = "https://codesign.llnl.gov/laghos.php"
- git = "https://github.com/CEED/Laghos"
+ homepage = "https://computation.llnl.gov/projects/co-design/laghos"
url = "https://github.com/CEED/Laghos/archive/v1.0.tar.gz"
+ git = "https://github.com/CEED/Laghos.git"
+
+ version('develop', branch='master')
+ version('1.1', sha256='53b9bfe2af263c63eb4544ca1731dd26f40b73a0d2775a9883db51821bf23b7f')
+ version('1.0', '4c091e115883c79bed81c557ef16baff')
+
+ variant('metis', default=True, description='Enable/disable METIS support')
- version('1.0', '107c2f693936723e764a4d404d33d44a')
- version('develop', git=git, branch='master')
+ depends_on('mfem@develop+mpi+metis', when='@develop+metis')
+ depends_on('mfem@develop+mpi~metis', when='@develop~metis')
- depends_on('mpi')
- depends_on('mfem@laghos-v1.0', when='@1.0')
+ depends_on('mfem@laghos-v1.0,3.3.2:+mpi+metis', when='@1.0:+metis')
+ depends_on('mfem@laghos-v1.0,3.3.2:+mpi~metis', when='@1.0:~metis')
@property
def build_targets(self):
@@ -49,13 +36,24 @@ class Laghos(MakefilePackage):
spec = self.spec
targets.append('MFEM_DIR=%s' % spec['mfem'].prefix)
- targets.append('CONFIG_MK=%s' % join_path(spec['mfem'].prefix,
- 'share/mfem/config.mk'))
- targets.append('TEST_MK=%s' % join_path(spec['mfem'].prefix,
- 'share/mfem/test.mk'))
+ targets.append('CONFIG_MK=%s' % spec['mfem'].package.config_mk)
+ targets.append('TEST_MK=%s' % spec['mfem'].package.test_mk)
+ targets.append('CXX=%s' % spec['mpi'].mpicxx)
return targets
+ # See lib/spack/spack/build_systems/makefile.py
+ def check(self):
+ targets = []
+ spec = self.spec
+
+ targets.append('MFEM_DIR=%s' % spec['mfem'].prefix)
+ targets.append('CONFIG_MK=%s' % spec['mfem'].package.config_mk)
+ targets.append('TEST_MK=%s' % spec['mfem'].package.test_mk)
+
+ with working_dir(self.build_directory):
+ make('test', *targets)
+
def install(self, spec, prefix):
mkdirp(prefix.bin)
install('laghos', prefix.bin)